summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-11-25 01:16:43 +0100
committerLucas Werkmeister2019-11-25 01:16:43 +0100
commitc4478a41ca755c8f4235ec4142f99edf5af2346b (patch)
tree06e13cde6640cc9f046a21c87f8f300fc1ba8cb2
parent38bfe4a3c37ea1228ff306c26a44416e7f693275 (diff)
downloadaur-graal-native-image-bin.tar.gz
Turn into virtual package for update to 19.3.0
With the 19.3.0 release, GraalVM supports two Java versions: Java 8 and Java 11. This also affects all sibling packages, including native-image, so the former graal-native-image-bin package is split in two: native-image-jdk8-bin and native-image-jdk11-bin. To leave old installs functional when they update, this package is retained, but only as a “virtual” package with no contents except for its dependencies. Since this package only used to provide the Java 8 version, it declares a dependency on native-image-jdk8-bin now (users may, if they want to, install native-image-jdk11-bin additionally or instead). Users should explicitly install the real package; I will remove this one eventually.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD61
2 files changed, 9 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4be231792213..4b85ca52311a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = graal-native-image-bin
- pkgdesc = Plugin to turn Graal-based applications into native binary images
- pkgver = 19.2.1
+ pkgdesc = Virtual package for backwards compatibility; please directly install native-image-jdk8-bin instead
+ pkgver = 19.3.0
pkgrel = 1
url = https://github.com/oracle/graal
arch = x86_64
license = custom
- depends = graal
- provides = graal-native-image
- conflicts = graal-native-image
- source = https://github.com/oracle/graal/releases/download/vm-19.2.1/native-image-installable-svm-linux-amd64-19.2.1.jar
- sha256sums = af7c51adc71371fb9f24561a8a14e458096379488d2aab54bc3d260e01072b7c
+ depends = native-image-jdk8-bin
pkgname = graal-native-image-bin
diff --git a/PKGBUILD b/PKGBUILD
index 929f6806cd28..ac71d78dfba1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,12 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
-pkgname__=native-image
-pkgname_=graal-${pkgname__}
-pkgname=${pkgname_}-bin
-pkgver_=19.2.1
-pkgver=${pkgver_/-/_}
+pkgname=graal-native-image-bin
+pkgver=19.3.0
pkgrel=1
-pkgdesc='Plugin to turn Graal-based applications into native binary images'
+pkgdesc='Virtual package for backwards compatibility; please directly install native-image-jdk8-bin instead'
arch=('x86_64')
url='https://github.com/oracle/graal'
license=('custom')
-depends=('graal')
-makedepends=()
-optdepends=()
-provides=("$pkgname_")
-conflicts=("$pkgname_")
-source=("https://github.com/oracle/graal/releases/download/vm-${pkgver_}/${pkgname__}-installable-svm-linux-amd64-${pkgver_}.jar")
-sha256sums=('af7c51adc71371fb9f24561a8a14e458096379488d2aab54bc3d260e01072b7c')
-
-package() {
- local file eq permissions mode name target
-
- mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/" "$pkgdir/usr/bin/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_NATIVEIMAGE.txt
-
- printf '\n' >> META-INF/permissions
- while read -r file eq permissions; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$file" "$eq" "$permissions"
- return 1
- fi
- case $permissions in
- 'rw-------') mode=600;;
- 'rw-r--r--') mode=644;;
- 'rw-rw-r--') mode=664;;
- 'rwxr-xr-x') mode=755;;
- 'rwxrwxr-x') mode=775;;
- 'rwxrwxrwx') continue;; # symbolic link
- *)
- printf >&2 'unknown permissions: %s\n' "$permissions"
- return 1
- ;;
- esac
- chmod "$mode" -- "$pkgdir/usr/lib/jvm/java-8-graal/$file"
- done < META-INF/permissions
-
- printf '\n' >> META-INF/symlinks
- while read -r name eq target; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$name" "$eq" "$target"
- return 1
- fi
- mkdir -p -- "$pkgdir/usr/lib/jvm/java-8-graal/$(dirname -- "$name")"
- ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
- done < META-INF/symlinks
-
- install -DTm644 LICENSE_NATIVEIMAGE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- ln -s ../lib/jvm/java-8-graal/bin/${pkgname__} "$pkgdir/usr/bin/"
-}
+depends=('native-image-jdk8-bin')
+source=()
+sha256sums=()