summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-08-22 10:50:45 +0200
committerLucas Werkmeister2019-08-22 10:50:45 +0200
commit385d38a0b014872c95be7c7f13f49b89e5fdc67d (patch)
tree98bd81e7ec042648a4506cc2a00409e8c5545f7e
parentff9d8fb28b7cd10f1207c3cf7882dfcb18173fb3 (diff)
downloadaur-385d38a0b014872c95be7c7f13f49b89e5fdc67d.tar.gz
Update to 19.2.0
The top-level license files turned from symlinks into proper files (oracle/fastr#90 [1]), so now we have to copy those as well. [1]: https://github.com/oracle/fastr/issues/90
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d9df9010ae0..3e5e1a839ad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jul 17 21:52:57 UTC 2019
pkgbase = graal-native-image-bin
pkgdesc = Plugin to turn Graal-based applications into native binary images
- pkgver = 19.1.1
+ pkgver = 19.2.0
pkgrel = 1
url = https://github.com/oracle/graal
arch = x86_64
@@ -10,8 +8,8 @@ pkgbase = graal-native-image-bin
depends = graal
provides = graal-native-image
conflicts = graal-native-image
- source = https://github.com/oracle/graal/releases/download/vm-19.1.1/native-image-installable-svm-linux-amd64-19.1.1.jar
- sha256sums = 6cb0ad9eafd480c58349771ad1ecfef45802019e5f3bccbc007ad3c4606c6d74
+ source = https://github.com/oracle/graal/releases/download/vm-19.2.0/native-image-installable-svm-linux-amd64-19.2.0.jar
+ sha256sums = cdaddcdf9ba275e3db5d2122206d462d075c79d39c9f9ab8a217d81c0caf521b
pkgname = graal-native-image-bin
diff --git a/PKGBUILD b/PKGBUILD
index c1abd5249293..8b6dc760a1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname__=native-image
pkgname_=graal-${pkgname__}
pkgname=${pkgname_}-bin
-pkgver_=19.1.1
+pkgver_=19.2.0
pkgver=${pkgver_/-/_}
pkgrel=1
pkgdesc='Plugin to turn Graal-based applications into native binary images'
@@ -16,13 +16,13 @@ optdepends=()
provides=("$pkgname_")
conflicts=("$pkgname_")
source=("https://github.com/oracle/graal/releases/download/vm-${pkgver_}/${pkgname__}-installable-svm-linux-amd64-${pkgver_}.jar")
-sha256sums=('6cb0ad9eafd480c58349771ad1ecfef45802019e5f3bccbc007ad3c4606c6d74')
+sha256sums=('cdaddcdf9ba275e3db5d2122206d462d075c79d39c9f9ab8a217d81c0caf521b')
package() {
local file eq permissions mode name target
mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/" "$pkgdir/usr/bin/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/
+ cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_NATIVEIMAGE.txt
printf '\n' >> META-INF/permissions
while read -r file eq permissions; do
@@ -55,7 +55,7 @@ package() {
ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
done < META-INF/symlinks
- install -DTm644 jre/lib/svm/LICENSE_NATIVEIMAGE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -DTm644 LICENSE_NATIVEIMAGE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
ln -s ../lib/jvm/java-8-graal/bin/${pkgname__} "$pkgdir/usr/bin/"
}