summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-05-31 17:49:53 +0200
committerLucas Werkmeister2019-05-31 17:50:54 +0200
commitd964baaa65f360aa2f37224077b32e0d18b4f2a6 (patch)
tree89bb678e7f6f8b674be9c41ed62929e71c5a0538
parent23cee886c38666638963c6fe205d584cd6d626fa (diff)
downloadaur-d964baaa65f360aa2f37224077b32e0d18b4f2a6.tar.gz
Fix symlink installed into /usr/bin/
The binary name is just native-image, not graal-native-image. (Perhaps that would also have been a better name for the package? fastr and truffleruby don’t have graal in the name either, after all.) Thanks to AUR user sogaiu [1] for the tip! [1]: https://aur.archlinux.org/account/sogaiu
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30b89d5aea7d..675208b79f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu May 30 10:54:23 UTC 2019
+# Fri May 31 15:49:39 UTC 2019
pkgbase = graal-native-image-bin
pkgdesc = Plugin to turn Graal-based applications into native binary images
pkgver = 19.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/oracle/graal
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index cec27c94a96d..1d3530cfe3e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
-pkgname_=graal-native-image
+pkgname__=native-image
+pkgname_=graal-${pkgname__}
pkgname=${pkgname_}-bin
pkgver_=19.0.0
pkgver=${pkgver_/-/_}
-pkgrel=1
+pkgrel=2 # TODO reset to 1 with the next pkgver change
pkgdesc='Plugin to turn Graal-based applications into native binary images'
arch=('x86_64')
url='https://github.com/oracle/graal'
@@ -14,7 +15,7 @@ makedepends=()
optdepends=()
provides=("$pkgname_")
conflicts=("$pkgname_")
-source=("https://github.com/oracle/graal/releases/download/vm-${pkgver_}/native-image-installable-svm-linux-amd64-${pkgver_}.jar")
+source=("https://github.com/oracle/graal/releases/download/vm-${pkgver_}/${pkgname__}-installable-svm-linux-amd64-${pkgver_}.jar")
sha256sums=('1c794a3c038f4e6bb90542cf13ba3c6c793dcd193462bf56b8713fd24386e344')
package() {
@@ -56,5 +57,5 @@ package() {
install -DTm644 jre/lib/svm/LICENSE_NATIVEIMAGE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- ln -s ../lib/jvm/java-8-graal/bin/${pkgname_} "$pkgdir/usr/bin/"
+ ln -s ../lib/jvm/java-8-graal/bin/${pkgname__} "$pkgdir/usr/bin/"
}