summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-11-25 01:08:13 +0100
committerLucas Werkmeister2019-11-25 01:08:13 +0100
commit366929a91b1622ec1fe9703c353900292dd0f961 (patch)
treef355d77be0a999e2dd881132ac855b1206741652
parent6d31e404c40114ab7aa7ee7a403b6f2ba8d51478 (diff)
downloadaur-graalpython-bin.tar.gz
Turn into virtual package for update to 19.3.0
With the 19.3.0 release, GraalVM supports two Java versions: Java 8 and Java 11. This also affects all sibling packages, including GraalPython, so the former graalpython-bin package is split in two: graalpython-jdk8-bin and graalpython-jdk11-bin. To leave old installs functional when they update, this package is retained, but only as a “virtual” package with no contents except for its dependencies. Since this package only used to provide the Java 8 version, it declares a dependency on graalpython-jdk8-bin now (users may, if they want to, install graalpython-jdk11-bin additionally or instead). Users should explicitly install the real package; I will remove this one eventually.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD60
2 files changed, 9 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b51a5816e21f..c3ebdf2feb62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = graalpython-bin
- pkgdesc = Graal based, high-performance implementation of the Python language (early development)
- pkgver = 19.2.1
+ pkgdesc = Virtual package for backwards compatibility; please directly install graalpython-jdk8-bin instead
+ pkgver = 19.3.0
pkgrel = 1
url = https://github.com/graalvm/graalpython
arch = x86_64
license = custom
- depends = graal
- provides = graalpython
- conflicts = graalpython
- source = https://github.com/graalvm/graalpython/releases/download/vm-19.2.1/python-installable-svm-linux-amd64-19.2.1.jar
- sha256sums = d26948ca968e46ba53925961912ba4ed3267fdb1fcb402d3bc96d47c8a8f7cd3
+ depends = graalpython-jdk8-bin
pkgname = graalpython-bin
diff --git a/PKGBUILD b/PKGBUILD
index 64135ca4bd9e..77265f3ec754 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,12 @@
# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
-pkgname_=graalpython
-pkgname=${pkgname_}-bin
-pkgver_=19.2.1
-pkgver=${pkgver_/-/_}
+pkgname=graalpython-bin
+pkgver=19.3.0
pkgrel=1
-pkgdesc='Graal based, high-performance implementation of the Python language (early development)'
+pkgdesc='Virtual package for backwards compatibility; please directly install graalpython-jdk8-bin instead'
arch=('x86_64')
url='https://github.com/graalvm/graalpython'
license=('custom')
-depends=('graal')
-makedepends=()
-optdepends=()
-provides=("$pkgname_")
-conflicts=("$pkgname_")
-source=("https://github.com/graalvm/$pkgname_/releases/download/vm-${pkgver_}/python-installable-svm-linux-amd64-${pkgver_}.jar")
-sha256sums=('d26948ca968e46ba53925961912ba4ed3267fdb1fcb402d3bc96d47c8a8f7cd3')
-
-package() {
- local file eq permissions mode name target
-
- mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/" "$pkgdir/usr/bin/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_GRAALPYTHON.txt 3rd_party_licenses_graalpython.txt
-
- printf '\n' >> META-INF/permissions
- while read -r file eq permissions; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$file" "$eq" "$permissions"
- return 1
- fi
- case $permissions in
- 'rw-------') mode=600;;
- 'rw-r--r--') mode=644;;
- 'rw-rw-r--') mode=664;;
- 'rwxr-xr-x') mode=755;;
- 'rwxrwxr-x') mode=775;;
- 'rwxrwxrwx') continue;; # symbolic link
- *)
- printf >&2 'unknown permissions: %s\n' "$permissions"
- return 1
- ;;
- esac
- chmod "$mode" -- "$pkgdir/usr/lib/jvm/java-8-graal/$file"
- done < META-INF/permissions
-
- printf '\n' >> META-INF/symlinks
- while read -r name eq target; do
- if [[ $eq != '=' ]]; then
- printf >&2 'second word should be "=": %s %s %s\n' "$name" "$eq" "$target"
- return 1
- fi
- mkdir -p -- "$pkgdir/usr/lib/jvm/java-8-graal/$(dirname -- "$name")"
- ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
- done < META-INF/symlinks
-
- install -DTm644 LICENSE_GRAALPYTHON.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- ln -s ../lib/jvm/java-8-graal/bin/${pkgname_} "$pkgdir/usr/bin/"
-}
+depends=('graalpython-jdk8-bin')
+source=()
+sha256sums=()