summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-08-22 10:50:07 +0200
committerLucas Werkmeister2019-08-22 10:50:07 +0200
commit07ef3d2d3a6b4c2a9b13a266fdd915e80d9aacc0 (patch)
treec3b05c179848c128c0bf504b5b8600e8cae044a2
parent3a035fdd137a612165c328323340e1aa6577cb57 (diff)
downloadaur-07ef3d2d3a6b4c2a9b13a266fdd915e80d9aacc0.tar.gz
Update to 19.2.0
The top-level license files turned from symlinks into proper files (oracle/fastr#90 [1]), so now we have to copy those as well. [1]: https://github.com/oracle/fastr/issues/90
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f96ecdf78ca9..d346fb7d2147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jul 17 21:52:56 UTC 2019
pkgbase = graalpython-bin
pkgdesc = Graal based, high-performance implementation of the Python language (early development)
- pkgver = 19.1.1
+ pkgver = 19.2.0
pkgrel = 1
url = https://github.com/graalvm/graalpython
arch = x86_64
@@ -10,8 +8,8 @@ pkgbase = graalpython-bin
depends = graal
provides = graalpython
conflicts = graalpython
- source = https://github.com/graalvm/graalpython/releases/download/vm-19.1.1/python-installable-svm-linux-amd64-19.1.1.jar
- sha256sums = 6887026a1cb161d0cf80a84ee2f7e6e7a7a7c19bc2dbcd77a733c90e938ce3f6
+ source = https://github.com/graalvm/graalpython/releases/download/vm-19.2.0/python-installable-svm-linux-amd64-19.2.0.jar
+ sha256sums = ef0eba0b18922f5d6b1413dc3fd478c6d48b07b3ac0dee3e26c0b92c65bb217c
pkgname = graalpython-bin
diff --git a/PKGBUILD b/PKGBUILD
index 53f0021029a5..25335f68e406 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname_=graalpython
pkgname=${pkgname_}-bin
-pkgver_=19.1.1
+pkgver_=19.2.0
pkgver=${pkgver_/-/_}
pkgrel=1
pkgdesc='Graal based, high-performance implementation of the Python language (early development)'
@@ -15,13 +15,13 @@ optdepends=()
provides=("$pkgname_")
conflicts=("$pkgname_")
source=("https://github.com/graalvm/$pkgname_/releases/download/vm-${pkgver_}/python-installable-svm-linux-amd64-${pkgver_}.jar")
-sha256sums=('6887026a1cb161d0cf80a84ee2f7e6e7a7a7c19bc2dbcd77a733c90e938ce3f6')
+sha256sums=('ef0eba0b18922f5d6b1413dc3fd478c6d48b07b3ac0dee3e26c0b92c65bb217c')
package() {
local file eq permissions mode name target
mkdir -p "$pkgdir/usr/lib/jvm/java-8-graal/" "$pkgdir/usr/bin/"
- cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/
+ cp -a -t "$pkgdir/usr/lib/jvm/java-8-graal/" jre/ LICENSE_GRAALPYTHON.txt 3rd_party_licenses_graalpython.txt
printf '\n' >> META-INF/permissions
while read -r file eq permissions; do
@@ -54,7 +54,7 @@ package() {
ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
done < META-INF/symlinks
- install -DTm644 jre/languages/python/LICENSE_GRAALPYTHON.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -DTm644 LICENSE_GRAALPYTHON.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
ln -s ../lib/jvm/java-8-graal/bin/${pkgname_} "$pkgdir/usr/bin/"
}