summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2019-05-12 05:09:23 +0200
committerLucas Werkmeister2019-05-12 05:09:23 +0200
commit4129fae7ff8ff14edd89a69327fbc67250919c5f (patch)
treed35dd5f64293e9a71d4a46b53dd227a75e3f7dbe
parent5ed01e49a2e313842b208c7355ea3d79e3bffedd (diff)
downloadaur-4129fae7ff8ff14edd89a69327fbc67250919c5f.tar.gz
Update to 19.0.0
The first non-RC release changed the source file name pattern a bit, and standardized the license file names to end in .txt, but otherwise the package format remained stable.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a55da25debf..ede1322191bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 26 20:57:41 UTC 2019
+# Sun May 12 03:09:22 UTC 2019
pkgbase = graalpython-bin
pkgdesc = Graal based, high-performance implementation of the Python language (early development)
- pkgver = 1.0.0_rc16
+ pkgver = 19.0.0
pkgrel = 2
url = https://github.com/graalvm/graalpython
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = graalpython-bin
depends = graal
provides = graalpython
conflicts = graalpython
- source = https://github.com/graalvm/graalpython/releases/download/vm-1.0.0-rc16/python-installable-ce-1.0.0-rc16-linux-amd64.jar
- sha256sums = 314ba1bd3180278b8cdaaae34aa122d5b1f5ba977283d551d82b679e3307b396
+ source = https://github.com/graalvm/graalpython/releases/download/vm-19.0.0/python-installable-svm-linux-amd64-19.0.0.jar
+ sha256sums = 685c4fa67b33f53ae516288512b04a69bdb12dde9e04f8b97da19a6fb879f9ae
pkgname = graalpython-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1f834eb17594..b3b2f35d4bc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname_=graalpython
pkgname=${pkgname_}-bin
-pkgver_=1.0.0-rc16
+pkgver_=19.0.0
pkgver=${pkgver_/-/_}
pkgrel=2
pkgdesc='Graal based, high-performance implementation of the Python language (early development)'
@@ -14,8 +14,8 @@ makedepends=()
optdepends=()
provides=("$pkgname_")
conflicts=("$pkgname_")
-source=("https://github.com/graalvm/$pkgname_/releases/download/vm-${pkgver_}/python-installable-ce-${pkgver_}-linux-amd64.jar")
-sha256sums=('314ba1bd3180278b8cdaaae34aa122d5b1f5ba977283d551d82b679e3307b396')
+source=("https://github.com/graalvm/$pkgname_/releases/download/vm-${pkgver_}/python-installable-svm-linux-amd64-${pkgver_}.jar")
+sha256sums=('685c4fa67b33f53ae516288512b04a69bdb12dde9e04f8b97da19a6fb879f9ae')
package() {
local file eq permissions mode name target
@@ -54,7 +54,7 @@ package() {
ln -s -- "$target" "$pkgdir/usr/lib/jvm/java-8-graal/$name"
done < META-INF/symlinks
- install -DTm644 jre/languages/python/LICENSE_GRAALPYTHON "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -DTm644 jre/languages/python/LICENSE_GRAALPYTHON.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
ln -s ../lib/jvm/java-8-graal/bin/${pkgname_} "$pkgdir/usr/bin/"
}