summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Duszynski2016-09-29 18:54:33 +0200
committerTomasz Duszynski2016-09-29 18:54:33 +0200
commit2ce15904c8d1409e9fa3f7fb01f8a0c9d2f576ea (patch)
tree8107b375e155d59b89fff085edf8a7c39a3faeca
downloadaur-2ce15904c8d1409e9fa3f7fb01f8a0c9d2f576ea.tar.gz
add grabserial PKGFILE
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcbca868c3eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = grabserial
+ pkgdesc = Serial dump and timing program
+ pkgver = 1.9.2
+ pkgrel = 1
+ url = https://github.com/tbird20d/grabserial
+ arch = any
+ license = GPL v2
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2-pyserial
+ source = https://github.com/tbird20d/grabserial/archive/v1.9.2.tar.gz
+ md5sums = SKIP
+
+pkgname = grabserial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25c99b4e07eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tomasz Duszynski <tduszyns@gmail.com>
+
+pkgname=grabserial
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Serial dump and timing program"
+arch=('any')
+url="https://github.com/tbird20d/grabserial"
+license=('GPL v2')
+depends=('python2-pyserial')
+makedepends=('git' 'python2-setuptools')
+source=("https://github.com/tbird20d/grabserial/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir
+
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -D -m644 README $pkgdir/usr/share/doc/$pkgname/README
+ install -d $pkgdir/usr/share/doc/$pkgname/examples
+ mv test.sh $pkgdir/usr/share/doc/$pkgname/examples/test.sh
+}