summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Bergmark2018-05-22 00:08:55 +0200
committerMagnus Bergmark2018-05-22 00:08:55 +0200
commit492f17c3d3c241d24618a14a90f058ec14179cb8 (patch)
tree9005ef5632162d4cac2a46a64c475c8e94faa4c3
downloadaur-492f17c3d3c241d24618a14a90f058ec14179cb8.tar.gz
Release version 0.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD44
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e8df6ea553d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = graceful-shutdown
+ pkgdesc = Terminate a list of processes and wait for them to exit.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Mange/graceful-shutdown
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/Mange/graceful-shutdown/archive/v0.1.0.tar.gz
+ sha512sums = cca3f83499da0cbd6c9f9fd32723bc5fcfc402960201a8aa7ecb880dc8e2af45a403375ce8178cfade26c7b9136e125ed7e24b3a0b2f97add2959941a4001d69
+
+pkgname = graceful-shutdown
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71a69ae7d4ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Magnus Bergmark <magnus.bergmark@gmail.com>
+pkgname=graceful-shutdown
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Terminate a list of processes and wait for them to exit."
+arch=('x86_64')
+url="https://github.com/Mange/$pkgname"
+license=('MIT')
+depends=()
+makedepends=('cargo')
+source=("https://github.com/Mange/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('cca3f83499da0cbd6c9f9fd32723bc5fcfc402960201a8aa7ecb880dc8e2af45a403375ce8178cfade26c7b9136e125ed7e24b3a0b2f97add2959941a4001d69')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+
+ # Generate completion scripts
+ mkdir -p target/release/completions
+ "./target/release/$pkgname" \
+ --generate-completions bash > "target/release/completions/$pkgname.bash"
+ "./target/release/$pkgname" \
+ --generate-completions fish > "target/release/completions/$pkgname.fish"
+ "./target/release/$pkgname" \
+ --generate-completions zsh > "target/release/completions/_$pkgname"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ local builddir=target/release
+
+ install -Dm755 "$builddir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ install -Dm644 "$builddir/completions/_$pkgname" "$pkgdir/usr/share/zsh/site-functions/_$pkgname"
+ install -Dm644 "$builddir/completions/$pkgname.bash" "$pkgdir/usr/share/bash-completion/completions/$pkgname"
+ install -Dm644 "$builddir/completions/$pkgname.fish" "$pkgdir/usr/share/fish/completions/$pkgname.fish"
+
+ install -Dm644 man/$pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+