aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordingjing2022-04-30 13:05:40 +0800
committerdingjing2022-04-30 13:05:40 +0800
commitb6ab70d8173f951aa0463711f94821311d720d4e (patch)
tree5e3d2e9120a9e04beca3609e7f19597a4af3147d
downloadaur-b6ab70d8173f951aa0463711f94821311d720d4e.tar.gz
pkg name
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD48
-rw-r--r--README.md1
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5894eaeb3aa9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = graceful-udisks
+ pkgdesc = 原始项目: https://www.freedesktop.org/wiki/Software/udisks, 本项目仅用于个人调试,不能用于生产环境,否则会造成不可预估的损失,使用本包造成的损失由自己承担。
+ pkgver = 2.9.4
+ pkgrel = 1
+ url = https://github.com/graceful-linux/udisks
+ arch = x86_64
+ license = GPL2
+ makedepends = docbook-xsl
+ makedepends = gobject-introspection
+ makedepends = parted
+ makedepends = gtk-doc
+ depends = polkit
+ depends = libatasmart
+ depends = libgudev
+ depends = libblockdev
+ optdepends = gptfdisk: GUID partition table support
+ optdepends = ntfs-3g: NTFS filesystem management support
+ optdepends = dosfstools: VFAT filesystem management support
+ provides = udisks2=2.9.4
+ conflicts = udisks2
+ backup = etc/udisks2/udisks2.conf
+ source = https://github.com/graceful-linux/udisks/archive/refs/tags/udisks-debug-2.9.4.tar.gz
+ sha512sums = 3836f6d2d6fe02eb9cccbb85d940bb5b4a07db1dafe7beba1f2ded110b04de03b1e0b79e11592c3a9b2f0e047ae4fc4284d895a953e1f4dd042e544634e505ca
+
+pkgname = graceful-udisks
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..45e74aaa3822
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.zst
+pkg/
+src/
+*.tar.gz
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6303cfcf4cee
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2022 graceful-linux
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75910b43ae01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: dingjing <dingjing@live.cn>
+
+pkgname=graceful-udisks
+_pkgname=udisks2
+pkgver=2.9.4
+pkgrel=1
+pkgdesc='原始项目: https://www.freedesktop.org/wiki/Software/udisks, 本项目仅用于个人调试,不能用于生产环境,否则会造成不可预估的损失,使用本包造成的损失由自己承担。'
+arch=('x86_64')
+url="https://github.com/graceful-linux/udisks"
+license=('GPL2')
+depends=('polkit' 'libatasmart' 'libgudev' 'libblockdev')
+makedepends=('docbook-xsl' 'gobject-introspection' 'parted' 'gtk-doc')
+optdepends=('gptfdisk: GUID partition table support'
+ 'ntfs-3g: NTFS filesystem management support'
+ 'dosfstools: VFAT filesystem management support')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+backup=('etc/udisks2/udisks2.conf')
+source=("https://github.com/graceful-linux/udisks/archive/refs/tags/udisks-debug-2.9.4.tar.gz")
+sha512sums=('3836f6d2d6fe02eb9cccbb85d940bb5b4a07db1dafe7beba1f2ded110b04de03b1e0b79e11592c3a9b2f0e047ae4fc4284d895a953e1f4dd042e544634e505ca')
+
+prepare() {
+ mv udisks-udisks-debug-$pkgver udisks-udisks-$pkgver
+ cd udisks-udisks-$pkgver
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd udisks-udisks-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --sbindir=/usr/bin --libexecdir=/usr/lib \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --localstatedir=/var --disable-static \
+ --enable-gtk-doc enable_available_modules=yes
+ make
+}
+
+check() {
+ cd udisks-udisks-$pkgver
+ make check
+}
+
+package() {
+ cd udisks-udisks-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e5ace025f330
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+# udisks2-pkg \ No newline at end of file