summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0xMRTT2022-09-15 18:32:57 +0200
committer0xMRTT2022-09-15 18:32:57 +0200
commita31eb632981c508e2306fc939c5082bf794a6200 (patch)
tree48fe57216be5820936fbeec75ad89363cd9d3728
downloadaur-a31eb632981c508e2306fc939c5082bf794a6200.tar.gz
feat: add backgrounds
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88a0f4675394
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gradience-backgrounds
+ pkgdesc = Gradience Backgrounds
+ pkgver = 0.2.3
+ pkgrel = 2
+ url = https://github.com/GradienceTeam/Design
+ arch = any
+ license = GPLv3
+ makedepends = git
+ source = git+https://github.com/GradienceTeam/Design
+ sha256sums = SKIP
+
+pkgname = gradience-backgrounds
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a2f4f7967ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: 0xMRTT < 0xMRTT at proton dot me >
+
+pkgname="gradience-backgrounds"
+pkgver=0.2.3
+pkgrel=2
+pkgdesc='Gradience Backgrounds'
+arch=('any')
+url="https://github.com/GradienceTeam/Design"
+license=('GPLv3')
+source=("git+$url")
+makedepends=('git')
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/Design/Backgrounds"
+
+ find . \
+ -type f \
+ \( -name "*.png" -o -name "*.svg" \) \
+ -exec install -Dm 0755 -t "$pkgdir/usr/share/backgrounds/gradience/." {} +
+}