summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBilal Elmoussaoui2017-09-13 11:33:20 +0200
committerBilal Elmoussaoui2017-09-13 11:33:20 +0200
commitd4b1cdb95f5b5b29194a297a2f950327cc281f80 (patch)
treea556a4160c52118ea4a47cba3858000abe4311c7
parent35d877e009faa4815ce7ce411d153b9a72ab7ef5 (diff)
downloadaur-d4b1cdb95f5b5b29194a297a2f950327cc281f80.tar.gz
update to the latest version
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD30
-rw-r--r--gradio.install13
4 files changed, 30 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a4aeda4b230..ebbabcf15dc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,35 @@
pkgbase = gradio
pkgdesc = A GTK3 app for finding and listening to internet radio stations
- pkgver = 5.0
- pkgrel = 2
+ pkgver = 6.0
+ pkgrel = 1
url = https://github.com/haecker-felix/gradio
- install = gradio.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = unzip
makedepends = gnome-common
- makedepends = intltool
- makedepends = itstool
+ makedepends = meson
+ makedepends = gettext
+ makedepends = appstream-glib
makedepends = vala
makedepends = yelp-tools
- makedepends = cmake
depends = desktop-file-utils
depends = gstreamer
depends = gst-plugins-ugly
depends = gst-plugins-bad
+ depends = gtk3
+ depends = gobject-introspection
depends = gst-plugins-base
depends = gst-plugins-good
depends = json-glib
depends = libgee
+ depends = sqlite3
depends = libsoup
- provides = gradio=5.0
+ provides = gradio=6.0
conflicts = gradio-git
conflicts = gradio-bin
options = !emptydirs
- source = https://github.com/haecker-felix/gradio/archive/v5.0.zip
- md5sums = 4c61f411f9e90e5e202aabcabe71e1f7
+ source = https://github.com/haecker-felix/gradio/archive/v6.0.tar.gz
+ sha256sums = e52c72b50d12242b98dd716a6c18889873318bb25dcd70fb27b930a5ba451ea2
pkgname = gradio
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..477e78e0ef0e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.tar
+*.pkg.tar.xz
+pkg/
+src/
+*.zip
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f0028b604caf..a3401fcab035 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,28 @@
pkgname=gradio
_gitname=gradio
-pkgver=5.0
-_pkgver=5.0
-pkgrel=2
+pkgver=6.0
+pkgrel=1
pkgdesc='A GTK3 app for finding and listening to internet radio stations'
arch=('i686' 'x86_64')
license=('GPL3')
url="https://github.com/haecker-felix/gradio"
-depends=('desktop-file-utils' 'gstreamer' 'gst-plugins-ugly'
-'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'json-glib'
-'libgee'
-'libsoup')
-makedepends=('unzip' 'gnome-common' 'intltool' 'itstool' 'vala' 'yelp-tools' 'cmake')
+depends=('desktop-file-utils' 'gstreamer' 'gst-plugins-ugly'
+'gst-plugins-bad' 'gtk3' 'gobject-introspection' 'gst-plugins-base' 'gst-plugins-good' 'json-glib'
+'libgee' 'sqlite3' 'libsoup')
+makedepends=('gnome-common' 'meson' 'gettext' 'appstream-glib' 'vala' 'yelp-tools')
options=('!emptydirs')
-install=gradio.install
-source=("https://github.com/haecker-felix/${_gitname}/archive/v${_pkgver}.zip")
-md5sums=('4c61f411f9e90e5e202aabcabe71e1f7')
+source=("https://github.com/haecker-felix/${_gitname}/archive/v${pkgver}.tar.gz")
+sha256sums=('e52c72b50d12242b98dd716a6c18889873318bb25dcd70fb27b930a5ba451ea2')
conflicts=('gradio-git' 'gradio-bin')
-provides=("gradio=$_pkgver")
+provides=("gradio=${pkgver}")
build() {
- cd "$srcdir/gradio-${_pkgver}"
- ./autogen.sh --prefix=/usr
- make
+ cd "${srcdir}/gradio-${pkgver}"
+ meson builddir --prefix=/usr
}
package() {
- cd "$srcdir/gradio-${_pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/gradio-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C builddir install
}
diff --git a/gradio.install b/gradio.install
deleted file mode 100644
index ffc8ad906888..000000000000
--- a/gradio.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- glib-compile-schemas usr/share/glib-2.0/schemas
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-} \ No newline at end of file