summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBilal Elmoussaoui2016-06-05 00:05:17 +0200
committerBilal Elmoussaoui2016-06-05 00:05:17 +0200
commit247685eb45fc4c1d6f31584ced9967c2e861a24c (patch)
tree10d15a829a592878ceb5df26245cdacda7eb60c9
downloadaur-247685eb45fc4c1d6f31584ced9967c2e861a24c.tar.gz
first build
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD32
-rw-r--r--gradio.install13
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..357e2b3a2290
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gradio-git
+ pkgdesc = A Reddit Client For GNOME (with Gtk+ and Python)
+ pkgver = 2.3
+ pkgrel = 1
+ url = https://github.com/haecker-felix/gradio
+ install = gradio.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = intltool
+ makedepends = itstool
+ makedepends = vala
+ makedepends = yelp-tools
+ makedepends = cmake
+ depends = desktop-file-utils
+ depends = gstreamer
+ depends = json-glib
+ depends = libgee
+ depends = libsoup
+ provides = gradio=2.3
+ options = !emptydirs
+ source = git://github.com/haecker-felix/gradio.git
+ md5sums = SKIP
+
+pkgname = gradio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c11eae36f96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: ELmoussaoui Bilal <bil.elmoussaoui@gmail.com>
+
+pkgname=gradio-git
+_gitname=gradio
+pkgver=2.3
+pkgrel=1
+pkgdesc='A Reddit Client For GNOME (with Gtk+ and Python)'
+arch=('i686' 'x86_64')
+license=('GPL3')
+url="https://github.com/haecker-felix/gradio"
+depends=('desktop-file-utils' 'gstreamer' 'json-glib' 'libgee' 'libsoup')
+makedepends=('git' 'gnome-common' 'intltool' 'itstool' 'vala' 'yelp-tools' 'cmake')
+
+options=('!emptydirs')
+install=gradio.install
+source=("git://github.com/haecker-felix/${_gitname}.git")
+md5sums=('SKIP')
+conflicts=('')
+provides=("gradio=$pkgver")
+
+build() {
+ cd "$srcdir/${_gitname}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file
diff --git a/gradio.install b/gradio.install
new file mode 100644
index 000000000000..ffc8ad906888
--- /dev/null
+++ b/gradio.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file