summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2017-12-06 08:45:09 -0500
committerMatthew McGinn2017-12-06 08:45:09 -0500
commit785bf36637ac9e8704313570ac87c89c1f4369e1 (patch)
treefdd8e9a7a547cc119fd8abfcf901b8ee4f7ef4e4
parentc11161556f41cb070cc38bfdc7e6d2398b70d282 (diff)
downloadaur-785bf36637ac9e8704313570ac87c89c1f4369e1.tar.gz
target any arch
update build process & makedepends
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5e2aa15020c..e8aff845d884 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Oct 1 20:43:46 UTC 2017
+# Wed Dec 6 13:44:15 UTC 2017
pkgbase = grafana-git
pkgdesc = A general purpose dashboard and graph composer. It supports graphite, influxdb or opentsdb
- pkgver = v4.5.1.r205.gfea741d7c
+ pkgver = v4.6.0.beta1.r415.g48d9d0d35
pkgrel = 1
url = http://grafana.org
install = grafana.install
- arch = x86_64
- arch = i686
+ arch = any
license = APACHE
makedepends = go
makedepends = nodejs-grunt-cli
makedepends = npm
+ makedepends = git
+ makedepends = yarn
+ makedepends = python2
provides = grafana
conflicts = grafana
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 22c7d0b974c6..7a2de880cb36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Gilles Hamel <hamelg at laposte dot net>
_pkgname=grafana
pkgname=${_pkgname}-git
-pkgver=v4.5.1.r205.gfea741d7c
+pkgver=v4.6.0.beta1.r415.g48d9d0d35
pkgrel=1
pkgdesc="A general purpose dashboard and graph composer. It supports graphite, influxdb or opentsdb"
url="http://grafana.org"
-arch=('x86_64' 'i686')
+arch=('any')
license=('APACHE')
-makedepends=('go' 'nodejs-grunt-cli' 'npm')
+makedepends=('go' 'nodejs-grunt-cli' 'npm' 'git' 'yarn' 'python2')
provides=('grafana')
options=('!strip' '!emptydirs')
conflicts=('grafana')
@@ -34,7 +34,7 @@ build() {
go run build.go setup
go run build.go build
# Build frontend assets
- npm install
+ yarn install --pure-lockfile
npm run build
}