summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2016-01-01 22:51:39 +1000
committerJustin Dray2016-01-01 22:51:39 +1000
commitc07b883e90bf075c7fbf2d9916c4a0a33d341043 (patch)
tree49459fdd16f81888477849977558965af2ff8fc9
parent7e42516a5cab1e2dc27180c33360b8ce20645847 (diff)
downloadaur-c07b883e90bf075c7fbf2d9916c4a0a33d341043.tar.gz
Updated config.patch for new version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--config.patch15
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cea1e579ce8..c9704533a563 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Jan 1 12:51:28 UTC 2016
pkgbase = grafana-git
pkgdesc = A general purpose dashboard and graph composer. It supports graphite, influxdb or opentsdb
- pkgver = v2.5.0.r23.g59fc72d
+ pkgver = v2.6.0.r179.gc0cf0cb
pkgrel = 1
url = http://grafana.org
install = grafana.install
@@ -18,7 +20,7 @@ pkgbase = grafana-git
source = config.patch
source = grafana.service
md5sums = SKIP
- md5sums = f676cfe7bdd2463e2600ff8fce75a2d6
+ md5sums = 6e514b0d3aea075d5349be463ff6daeb
md5sums = 05508c9c21f4c93ad86944a52d37e925
pkgname = grafana-git
diff --git a/PKGBUILD b/PKGBUILD
index 7c09d98805eb..3793213db8d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Gilles Hamel <hamelg at laposte dot net>
_pkgname=grafana
pkgname=${_pkgname}-git
-pkgver=v2.5.0.r23.g59fc72d
+pkgver=v2.6.0.r179.gc0cf0cb
pkgrel=1
pkgdesc="A general purpose dashboard and graph composer. It supports graphite, influxdb or opentsdb"
url="http://grafana.org"
@@ -18,7 +18,7 @@ source=("git+https://github.com/${_pkgname}/${_pkgname}"
"config.patch"
"grafana.service")
md5sums=('SKIP'
- 'f676cfe7bdd2463e2600ff8fce75a2d6'
+ '6e514b0d3aea075d5349be463ff6daeb'
'05508c9c21f4c93ad86944a52d37e925')
pkgver() {
diff --git a/config.patch b/config.patch
index 5a757d4b90b9..066436470b43 100644
--- a/config.patch
+++ b/config.patch
@@ -1,8 +1,8 @@
diff --git a/conf/defaults.ini b/conf/defaults.ini
-index 258a019..6a7bd6b 100644
+index 0693044..da59457 100644
--- a/conf/defaults.ini
+++ b/conf/defaults.ini
-@@ -9,11 +9,11 @@ app_mode = production
+@@ -10,15 +10,15 @@ app_mode = production
[paths]
# Path to where grafana can store temp files, sessions, and the sqlite3 db (if that is used)
#
@@ -13,10 +13,15 @@ index 258a019..6a7bd6b 100644
#
-logs = data/log
+logs = /var/log/grafana
+ #
+ # Directory where grafana will automatically scan and look for plugins
+ #
+-plugins = data/plugins
++plugins = /var/lib/grafana/plugins
#################################### Server ####################################
[server]
-@@ -40,7 +40,7 @@ root_url = %(protocol)s://%(domain)s:%(http_port)s/
+@@ -45,7 +45,7 @@ root_url = %(protocol)s://%(domain)s:%(http_port)s/
router_logging = false
# the path relative working path
@@ -25,7 +30,7 @@ index 258a019..6a7bd6b 100644
# enable gzip
enable_gzip = false
-@@ -62,7 +62,7 @@ password =
+@@ -67,7 +67,7 @@ password =
ssl_mode = disable
# For "sqlite3" only, path relative to data_path setting
@@ -35,7 +40,7 @@ index 258a019..6a7bd6b 100644
#################################### Session ####################################
[session]
diff --git a/pkg/components/renderer/renderer.go b/pkg/components/renderer/renderer.go
-index 9d5ddd0..aa0aa9e 100644
+index ec11a9a..01862ee 100644
--- a/pkg/components/renderer/renderer.go
+++ b/pkg/components/renderer/renderer.go
@@ -21,7 +21,7 @@ type RenderOpts struct {