summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorniQo2015-06-09 23:34:04 +0200
committerniQo2015-06-09 23:34:04 +0200
commitc0d4a521e97582bb603fc06fc661840ac1d82957 (patch)
treef3114b3dd4bbc80c014a183a94383e82c010037e
downloadaur-c0d4a521e97582bb603fc06fc661840ac1d82957.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..910be043e9a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = grail
+ pkgdesc = Gesture Recognition And Instantiation Library
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://launchpad.net/grail
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = inputproto
+ depends = frame>=2.5.0
+ depends = libxi
+ conflicts = utouch-grail
+ replaces = utouch-grail
+ options = !libtool
+ source = http://launchpad.net/grail/trunk/3.1.0/+download/grail-3.1.0.tar.gz
+ md5sums = f0f8c56430ee3717778dec6452201c33
+
+pkgname = grail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0832e9b17ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Nicolas QuiƩnot <niQo @ aur>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Contributor: thn81 <root@scrat>
+
+pkgname=grail
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="Gesture Recognition And Instantiation Library"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/grail"
+license=('GPL')
+depends=('frame>=2.5.0' 'libxi')
+makedepends=('inputproto')
+conflicts=('utouch-grail')
+replaces=('utouch-grail')
+options=('!libtool')
+source=("http://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz")
+md5sums=('f0f8c56430ee3717778dec6452201c33')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # Static library needed for tests
+ ./configure --prefix=/usr # --disable-static
+ MAKEFLAGS="-j1"
+ make ${MAKEFLAGS}
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+