summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Groß2022-03-23 23:40:18 +0100
committerMagnus Groß2022-03-23 23:40:18 +0100
commit1ccc89887643ddc9274126ded67a22d24db3e66c (patch)
tree4cf691b648a3406f8594e29458b42ddbc3acd1aa
parent1d0e962c21afabedb8728570d5dcc59b7fe36f12 (diff)
downloadaur-1ccc89887643ddc9274126ded67a22d24db3e66c.tar.gz
Update to 3.6.4
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD71
-rw-r--r--link-perftest-against-jackd.patch17
3 files changed, 66 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdd3e080cc62..568062c6ae6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,25 @@
pkgbase = grandorgue-git
- pkgdesc = git-version of the Virtual Pipe Organ Software GrandOrgue
- pkgver = 2019.03.31.00.00.00
+ pkgdesc = Virtual Pipe Organ Software
+ pkgver = 3.6.4.1.r0.gdd388827
pkgrel = 1
- url = https://github.com/e9925248/grandorgue
+ url = https://github.com/GrandOrgue/grandorgue
arch = i686
arch = x86_64
license = GPL2+
- makedepends = gcc
- makedepends = cmake
makedepends = git
- makedepends = docbook-xsl
- makedepends = zip
- makedepends = po4a
- makedepends = gettext
- depends = fftw
- depends = wavpack
+ makedepends = cmake
+ makedepends = rtaudio
+ makedepends = rtmidi
+ makedepends = portaudio
depends = wxgtk2
- depends = alsa-lib
- depends = libglvnd
+ depends = wavpack
+ depends = fftw
depends = jack
- depends = zlib
- depends = libsystemd
- source = git+https://github.com/e9925248/grandorgue.git#branch=master
- md5sums = SKIP
+ source = git+https://github.com/GrandOrgue/grandorgue.git
+ source = git+https://github.com/GrandOrgue/ZitaConvolver.git
+ source = link-perftest-against-jackd.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 3c13c6a627cddff1710c106a000bffbaa31c390716f11d4588ddd4484cea9dc4
pkgname = grandorgue-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a54e28a708df..fc94e082fb55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,46 @@
-# Maintainer: Klaus Fröhlich <arch@sclause.net>
-
-pkgname=grandorgue-git
-pkgver=2019.03.31.00.00.00
-_branch=master
+# Maintainer: Magnus Groß, for email contact see AUR commit author email
+_pkgname=grandorgue
+pkgname="$_pkgname"-git
+pkgver=3.6.4.1.r0.gdd388827
pkgrel=1
-pkgdesc='git-version of the Virtual Pipe Organ Software GrandOrgue'
+pkgdesc="Virtual Pipe Organ Software"
arch=('i686' 'x86_64')
-url='https://github.com/e9925248/grandorgue'
+url="https://github.com/GrandOrgue/$_pkgname"
license=('GPL2+')
-depends=(fftw
- wavpack
- wxgtk2
- alsa-lib
- libglvnd
- jack
- zlib
- libsystemd)
-makedepends=(gcc
- cmake
- git
- docbook-xsl
- zip
- po4a
- gettext)
-source=("git+$url.git#branch=$_branch")
-md5sums=('SKIP')
+depends=(wxgtk2 wavpack fftw jack)
+makedepends=(git cmake rtaudio rtmidi portaudio)
+source=("git+$url.git"
+ "git+https://github.com/GrandOrgue/ZitaConvolver.git"
+ "link-perftest-against-jackd.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ '3c13c6a627cddff1710c106a000bffbaa31c390716f11d4588ddd4484cea9dc4')
pkgver() {
- cd grandorgue
- git log -1 --pretty=%aI | sed 's/\+.*//g;s/[^0-9]/\./g'
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$_pkgname"
+ # Unfortunately we are unable to use system zita at the moment
+ git submodule init submodules/ZitaConvolver
+ git config submodule.submodules/ZitaConvolver.url "$srcdir/ZitaConvolver"
+ git submodule update
+
+ patch -Np1 -i ../*.patch
}
build() {
- if [ ! -d gobuild ]; then
- mkdir gobuild
- fi
- cd gobuild
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -G "Unix Makefiles" ../grandorgue
- make
+ cd "$_pkgname"
+ cmake -B build -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release -DUSE_INTERNAL_RTAUDIO=Off -DUSE_INTERNAL_PORTAUDIO=Off
+ cmake --build build
}
package() {
- cd gobuild
- make DESTDIR="${pkgdir}" SUFFIX="-git" LABEL="Git Build" install
+ cd "$_pkgname"
+ DESTDIR=$pkgdir cmake --install build
}
-
diff --git a/link-perftest-against-jackd.patch b/link-perftest-against-jackd.patch
new file mode 100644
index 000000000000..9a9490dbdd4f
--- /dev/null
+++ b/link-perftest-against-jackd.patch
@@ -0,0 +1,17 @@
+Description: GrandOrguePerfTest needs to be linked against libjackd when GO uses Jack
+Author: Sébastien Villemot <sebastien@debian.org>
+Forwarded: https://github.com/GrandOrgue/grandorgue/pull/1094
+Last-Update: 2022-03-23
+---
+This patch is courtesy of https://salsa.debian.org/debian/grandorgue/-/blob/ac5739accae02a48c3afb549c1ac81d8299c09c2/debian/patches/link-perftest-against-jackd.patch
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/tools/CMakeLists.txt
++++ b/src/tools/CMakeLists.txt
+@@ -24,3 +24,7 @@ target_include_directories(GrandOrguePer
+ target_link_libraries(GrandOrguePerfTest golib)
+
+ add_custom_target(runperftest COMMAND GrandOrguePerfTest "${CMAKE_SOURCE_DIR}/tests" DEPENDS GrandOrguePerfTest)
++
++if (GO_USE_JACK STREQUAL "ON")
++ target_link_libraries(GrandOrguePerfTest PkgConfig::JACK)
++endif ()