summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSClause2019-06-12 07:54:15 +0200
committerSClause2019-06-12 07:54:15 +0200
commit1d0e962c21afabedb8728570d5dcc59b7fe36f12 (patch)
treef86fa304e6cff9be8e5856a6c9d28dc610d20541
parenta5166537090b0bce1748bc7a3fd56db2fa29a21c (diff)
downloadaur-1d0e962c21afabedb8728570d5dcc59b7fe36f12.tar.gz
Updated version / dependencies
Updated dependencies Updated pkgver calculation
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae00fec9299c..cdd3e080cc62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = grandorgue-git
- pkgdesc = git-version of the Virtual Pipe Organ GrandOrgue
- pkgver = 1.0
+ pkgdesc = git-version of the Virtual Pipe Organ Software GrandOrgue
+ pkgver = 2019.03.31.00.00.00
pkgrel = 1
url = https://github.com/e9925248/grandorgue
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2+
+ makedepends = gcc
makedepends = cmake
makedepends = git
makedepends = docbook-xsl
@@ -18,6 +19,8 @@ pkgbase = grandorgue-git
depends = alsa-lib
depends = libglvnd
depends = jack
+ depends = zlib
+ depends = libsystemd
source = git+https://github.com/e9925248/grandorgue.git#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1844db806c5f..a54e28a708df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Klaus Fröhlich <arch@sclause.net>
pkgname=grandorgue-git
-pkgver=1.0
+pkgver=2019.03.31.00.00.00
_branch=master
pkgrel=1
-pkgdesc='git-version of the Virtual Pipe Organ GrandOrgue'
+pkgdesc='git-version of the Virtual Pipe Organ Software GrandOrgue'
arch=('i686' 'x86_64')
url='https://github.com/e9925248/grandorgue'
-license=('GPL')
+license=('GPL2+')
depends=(fftw
wavpack
wxgtk2
alsa-lib
libglvnd
- jack)
-makedepends=(cmake
+ jack
+ zlib
+ libsystemd)
+makedepends=(gcc
+ cmake
git
docbook-xsl
zip
po4a
gettext)
-#optdepends=('lame: MP3 export')
-#install=musescore.install
source=("git+$url.git#branch=$_branch")
md5sums=('SKIP')
pkgver() {
cd grandorgue
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git log -1 --pretty=%aI | sed 's/\+.*//g;s/[^0-9]/\./g'
}
build() {