summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSClause2019-05-24 19:58:58 +0200
committerSClause2019-05-24 19:58:58 +0200
commita5166537090b0bce1748bc7a3fd56db2fa29a21c (patch)
tree0b4e2acc125a232697a69ad4b26d68cce2e68a86
downloadaur-a5166537090b0bce1748bc7a3fd56db2fa29a21c.tar.gz
GrandOrgue GIT package first commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae00fec9299c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = grandorgue-git
+ pkgdesc = git-version of the Virtual Pipe Organ GrandOrgue
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/e9925248/grandorgue
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = docbook-xsl
+ makedepends = zip
+ makedepends = po4a
+ makedepends = gettext
+ depends = fftw
+ depends = wavpack
+ depends = wxgtk2
+ depends = alsa-lib
+ depends = libglvnd
+ depends = jack
+ source = git+https://github.com/e9925248/grandorgue.git#branch=master
+ md5sums = SKIP
+
+pkgname = grandorgue-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1844db806c5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Klaus Fröhlich <arch@sclause.net>
+
+pkgname=grandorgue-git
+pkgver=1.0
+_branch=master
+pkgrel=1
+pkgdesc='git-version of the Virtual Pipe Organ GrandOrgue'
+arch=('i686' 'x86_64')
+url='https://github.com/e9925248/grandorgue'
+license=('GPL')
+depends=(fftw
+ wavpack
+ wxgtk2
+ alsa-lib
+ libglvnd
+ jack)
+makedepends=(cmake
+ git
+ docbook-xsl
+ zip
+ po4a
+ gettext)
+#optdepends=('lame: MP3 export')
+#install=musescore.install
+source=("git+$url.git#branch=$_branch")
+md5sums=('SKIP')
+
+pkgver() {
+ cd grandorgue
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ if [ ! -d gobuild ]; then
+ mkdir gobuild
+ fi
+ cd gobuild
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -G "Unix Makefiles" ../grandorgue
+ make
+}
+
+package() {
+ cd gobuild
+ make DESTDIR="${pkgdir}" SUFFIX="-git" LABEL="Git Build" install
+}
+