summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Groß2022-04-02 21:06:57 +0200
committerMagnus Groß2022-04-03 21:03:41 +0200
commitb077762630ed0d7a5a7f4e1a085a14fd2a092bd2 (patch)
tree90f6f854a5984f7b36dcd895af7cf6d41d49b8c1
parent48868a5b5853c79b9729be64fa2ebaa2c91a349e (diff)
downloadaur-b077762630ed0d7a5a7f4e1a085a14fd2a092bd2.tar.gz
Link against system zita-convolver
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 9 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95697deb10d6..0e9c898d7753 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grandorgue-git
pkgdesc = Virtual Pipe Organ Software
- pkgver = 3.6.4.1.r1.gfd3aa076
- pkgrel = 2
+ pkgver = 3.6.5.0.r3.g3bc15926
+ pkgrel = 1
url = https://github.com/GrandOrgue/grandorgue
arch = i686
arch = x86_64
@@ -16,11 +16,10 @@ pkgbase = grandorgue-git
depends = wavpack
depends = fftw
depends = jack
+ depends = zita-convolver
conflicts = grandorgue
conflicts = grandorgue-bin
source = git+https://github.com/GrandOrgue/grandorgue.git
- source = git+https://github.com/GrandOrgue/ZitaConvolver.git
- sha256sums = SKIP
sha256sums = SKIP
pkgname = grandorgue-git
diff --git a/PKGBUILD b/PKGBUILD
index c4e21826dc71..68190ba59ac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
# Maintainer: Magnus Groß, for email contact see AUR commit author email
_pkgname=grandorgue
pkgname="$_pkgname"-git
-pkgver=3.6.4.1.r1.gfd3aa076
-pkgrel=2
+pkgver=3.6.5.0.r3.g3bc15926
+pkgrel=1
pkgdesc="Virtual Pipe Organ Software"
arch=('i686' 'x86_64')
url="https://github.com/GrandOrgue/$_pkgname"
license=('GPL2+')
-depends=(wxgtk2 wavpack fftw jack)
+depends=(wxgtk2 wavpack fftw jack zita-convolver)
makedepends=(git cmake rtaudio rtmidi portaudio docbook-xsl)
conflicts=(grandorgue grandorgue-bin)
-source=("git+$url.git"
- "git+https://github.com/GrandOrgue/ZitaConvolver.git"
-)
-sha256sums=('SKIP'
- 'SKIP')
+source=("git+$url.git")
+sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -24,17 +21,9 @@ pkgver() {
)
}
-prepare() {
- cd "$_pkgname"
- # Unfortunately we are unable to use system zita at the moment
- git submodule init submodules/ZitaConvolver
- git config submodule.submodules/ZitaConvolver.url "$srcdir/ZitaConvolver"
- git submodule update
-}
-
build() {
cd "$_pkgname"
- cmake -B build -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release -DUSE_INTERNAL_RTAUDIO=Off -DUSE_INTERNAL_PORTAUDIO=Off
+ cmake -B build -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release -DUSE_INTERNAL_RTAUDIO=Off -DUSE_INTERNAL_PORTAUDIO=Off -DUSE_INTERNAL_ZITACONVOLVER=Off
cmake --build build
}