summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Groß2022-03-24 21:15:09 +0100
committerMagnus Groß2022-03-24 21:15:51 +0100
commitbe831ca3e06b863dde965711cd85da74e3370ba0 (patch)
treeb4feef013f844024020d6ab923931cfb52081ae0
parent8af0e89b0d7eb83c9e242279f0fbea0799125bd9 (diff)
downloadaur-be831ca3e06b863dde965711cd85da74e3370ba0.tar.gz
upgpkg: grandorgue-git 3.6.4.1.r1.gfd3aa076-1
Linking against jack is fixed upstream now
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--link-perftest-against-jackd.patch17
3 files changed, 6 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 214b9e695757..c083d636330c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grandorgue-git
pkgdesc = Virtual Pipe Organ Software
- pkgver = 3.6.4.1.r0.gdd388827
- pkgrel = 2
+ pkgver = 3.6.4.1.r1.gfd3aa076
+ pkgrel = 1
url = https://github.com/GrandOrgue/grandorgue
arch = i686
arch = x86_64
@@ -18,9 +18,7 @@ pkgbase = grandorgue-git
depends = jack
source = git+https://github.com/GrandOrgue/grandorgue.git
source = git+https://github.com/GrandOrgue/ZitaConvolver.git
- source = link-perftest-against-jackd.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 3c13c6a627cddff1710c106a000bffbaa31c390716f11d4588ddd4484cea9dc4
pkgname = grandorgue-git
diff --git a/PKGBUILD b/PKGBUILD
index c6f6437d30fe..958527c4cd0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Magnus Groß, for email contact see AUR commit author email
_pkgname=grandorgue
pkgname="$_pkgname"-git
-pkgver=3.6.4.1.r0.gdd388827
-pkgrel=2
+pkgver=3.6.4.1.r1.gfd3aa076
+pkgrel=1
pkgdesc="Virtual Pipe Organ Software"
arch=('i686' 'x86_64')
url="https://github.com/GrandOrgue/$_pkgname"
@@ -11,10 +11,9 @@ depends=(wxgtk2 wavpack fftw jack)
makedepends=(git cmake rtaudio rtmidi portaudio docbook-xsl)
source=("git+$url.git"
"git+https://github.com/GrandOrgue/ZitaConvolver.git"
- "link-perftest-against-jackd.patch")
+)
sha256sums=('SKIP'
- 'SKIP'
- '3c13c6a627cddff1710c106a000bffbaa31c390716f11d4588ddd4484cea9dc4')
+ 'SKIP')
pkgver() {
cd "$_pkgname"
@@ -30,8 +29,6 @@ prepare() {
git submodule init submodules/ZitaConvolver
git config submodule.submodules/ZitaConvolver.url "$srcdir/ZitaConvolver"
git submodule update
-
- patch -Np1 -i ../*.patch
}
build() {
diff --git a/link-perftest-against-jackd.patch b/link-perftest-against-jackd.patch
deleted file mode 100644
index 9a9490dbdd4f..000000000000
--- a/link-perftest-against-jackd.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: GrandOrguePerfTest needs to be linked against libjackd when GO uses Jack
-Author: Sébastien Villemot <sebastien@debian.org>
-Forwarded: https://github.com/GrandOrgue/grandorgue/pull/1094
-Last-Update: 2022-03-23
----
-This patch is courtesy of https://salsa.debian.org/debian/grandorgue/-/blob/ac5739accae02a48c3afb549c1ac81d8299c09c2/debian/patches/link-perftest-against-jackd.patch
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/src/tools/CMakeLists.txt
-+++ b/src/tools/CMakeLists.txt
-@@ -24,3 +24,7 @@ target_include_directories(GrandOrguePer
- target_link_libraries(GrandOrguePerfTest golib)
-
- add_custom_target(runperftest COMMAND GrandOrguePerfTest "${CMAKE_SOURCE_DIR}/tests" DEPENDS GrandOrguePerfTest)
-+
-+if (GO_USE_JACK STREQUAL "ON")
-+ target_link_libraries(GrandOrguePerfTest PkgConfig::JACK)
-+endif ()