summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-12-18 14:34:10 +0100
committerMaxime Gauduin2018-12-18 14:34:10 +0100
commit7b6323ef6f17057b6d549427b4f01308f7d0805b (patch)
treebd5539435dd4a92a67319c958476c508f01f27a4
parentdaa39de4bd7bc2579b6560f26f7a951842b5e247 (diff)
downloadaur-7b6323ef6f17057b6d549427b4f01308f7d0805b.tar.gz
switch to meson, again
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD60
2 files changed, 32 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f04f068e222..e721d60eb06f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,26 @@
# Generated by mksrcinfo v8
-# Mon May 1 13:21:51 UTC 2017
+# Tue Dec 18 13:34:10 UTC 2018
pkgbase = granite-git
pkgdesc = Library that extends Gtk+
- pkgver = r1902.0fa57d2
+ pkgver = 5.2.2.r2.f1b29f52
pkgrel = 1
url = https://github.com/elementary/granite
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = LGPL3
- makedepends = cmake
makedepends = git
makedepends = gobject-introspection
+ makedepends = meson
makedepends = vala
depends = cairo
depends = gdk-pixbuf2
depends = glib2
- depends = glibc
depends = gtk3
depends = libgee
depends = pango
provides = granite
provides = libgranite.so
conflicts = granite
- replaces = granite-bzr
source = git+https://github.com/elementary/granite.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7ee1a897db32..de99b34a715b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,48 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=granite-git
-pkgver=r1902.0fa57d2
+pkgver=5.2.2.r2.f1b29f52
pkgrel=1
pkgdesc='Library that extends Gtk+'
-arch=('i686' 'x86_64')
+arch=(x86_64)
url='https://github.com/elementary/granite'
-license=('LGPL3')
-groups=('pantheon-unstable')
-depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libgee' 'pango')
-makedepends=('cmake' 'git' 'gobject-introspection' 'vala')
-provides=('granite' 'libgranite.so')
-conflicts=('granite')
-replaces=('granite-bzr')
-source=('git+https://github.com/elementary/granite.git')
-sha256sums=('SKIP')
+license=(LGPL3)
+groups=(pantheon-unstable)
+depends=(
+ cairo
+ gdk-pixbuf2
+ glib2
+ gtk3
+ libgee
+ pango
+)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+)
+provides=(
+ granite
+ libgranite.so
+)
+conflicts=(granite)
+source=(git+https://github.com/elementary/granite.git)
+sha256sums=(SKIP)
pkgver() {
cd granite
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- cd granite
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ git describe --tags | sed 's/-/.r/; s/-g/./'
}
build() {
- cd granite/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib'
- make
+ arch-meson granite build
+ ninja -C build
}
package() {
- cd granite/build
-
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: