summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2023-03-02 10:34:58 -0500
committerFantix King2023-03-02 10:34:58 -0500
commita43ab133b5d1b6c8d48a04de1160599a253f4d81 (patch)
tree40da53cbb0d62a5efdda1a09642bf0ca4ba686b1
downloadaur-a43ab133b5d1b6c8d48a04de1160599a253f4d81.tar.gz
Granted 0.9.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70c68c4fe424
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = granted-bin
+ pkgdesc = Granted is a command line interface (CLI) tool which simplifies access to cloud roles and allows multiple cloud accounts to be opened in your web browser simultaneously.
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://granted.dev/
+ arch = x86_64
+ license = MIT
+ source = https://releases.commonfate.io/granted/v0.9.0/granted_0.9.0_linux_x86_64.tar.gz
+ sha256sums = 3398ffd1769216c6162acd7f94e585c0b3d1a1ac79dbd119a373a4f911b45780
+
+pkgname = granted-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f7e8fc0e86c5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/granted-bin*.pkg.tar.zst
+/granted_*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8194de11f51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Fantix King <fantix.king@gmail.com>
+pkgname=granted-bin
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Granted is a command line interface (CLI) tool which simplifies access to cloud roles and allows multiple cloud accounts to be opened in your web browser simultaneously."
+arch=('x86_64')
+url="https://granted.dev/"
+license=('MIT')
+source=("https://releases.commonfate.io/granted/v${pkgver}/granted_${pkgver}_linux_${arch}.tar.gz")
+sha256sums=('3398ffd1769216c6162acd7f94e585c0b3d1a1ac79dbd119a373a4f911b45780')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin/"
+ install -D ${srcdir}/{granted,assume{,.fish,go}} "${pkgdir}/usr/bin/"
+}