summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-23 20:43:51 +0300
committerDimitris Kiziridis2020-04-23 20:43:51 +0300
commit4d414eef71eae8b04742f49d263143f62ce13bc1 (patch)
tree70ab2f263d60ccb2ae23ee5dd580d1d1393f41d7
downloadaur-4d414eef71eae8b04742f49d263143f62ce13bc1.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6d3c477e61d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = grapes
+ pkgdesc = Easy way to distribute commands over SSH
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/yaronsumel/grapes
+ arch = x86_64
+ license = MIT
+ makedepends = go-pie
+ source = https://github.com/yaronsumel/grapes/archive/v0.3.1.tar.gz
+ sha256sums = 856e1c801df46a78bc089a089192aacce4cc8755dd83bcb95da896bdc205ac74
+
+pkgname = grapes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43f79be0e9de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=grapes
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Easy way to distribute commands over SSH"
+arch=('x86_64')
+url='https://github.com/yaronsumel/grapes'
+license=('MIT')
+makedepends=('go-pie')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('856e1c801df46a78bc089a089192aacce4cc8755dd83bcb95da896bdc205ac74')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p $srcdir/go
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ go get -d -v ./...
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export GOPATH="${srcdir}"/go
+ export PATH=$PATH:$GOPATH/bin
+ go build -mod=mod -v -o "${srcdir}/${pkgname}-bin"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 ../${pkgname}-bin "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ go clean -modcache #Remove go libraries
+} \ No newline at end of file