aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Carlin2020-07-03 19:47:55 +0200
committerBruno Carlin2020-07-03 20:09:45 +0200
commit6af06a01f724b7b560cdc0e23ab02d22148ba8cd (patch)
treecabd4c52e51eb57d6c467c5b58d4c228ccd289bd
downloadaur-6af06a01f724b7b560cdc0e23ab02d22148ba8cd.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD46
-rw-r--r--README.md29
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20a9fd18e139
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = graph-cli
+ pkgdesc = A CLI utility to create graphs from CSV files.
+ pkgver = 0.1.6
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/mcastorina/graph-cli
+ arch = any
+ license = GPL3
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-matplotlib
+ source = https://files.pythonhosted.org/packages/source/g/graph-cli/graph_cli-0.1.6.tar.gz
+ sha256sums = c3ed350f3089be108fbb6a1bd38d44d5ec38aa301202c661fe3783a64c98bc8d
+
+pkgname = graph-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a7ea2e0a6040
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b20e15d4d5ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Bruno Carlin <bruno+aur@bcarlin.net>
+pkgname=graph-cli
+pkgver=0.1.6
+pkgrel=1
+epoch=1
+pkgdesc="A CLI utility to create graphs from CSV files."
+arch=( any )
+url="https://github.com/mcastorina/graph-cli"
+license=('GPL3')
+depends=( 'python-numpy' 'python-pandas' 'python-matplotlib' )
+#makedepends=()
+#checkdepends=()
+#checkdepends=()
+#optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#options=()
+#install=
+#changelog=
+source=(
+ "https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/${pkgname/-/_}-$pkgver.tar.gz"
+)
+#noextract=()
+sha256sums=( c3ed350f3089be108fbb6a1bd38d44d5ec38aa301202c661fe3783a64c98bc8d )
+
+#prepare() {
+# cd "$pkgname-$pkgver"
+# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+#}
+#
+build() {
+ cd "${pkgname/-/_}-$pkgver"
+ python setup.py build
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ cd "${pkgname/-/_}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e9b5319df553
--- /dev/null
+++ b/README.md
@@ -0,0 +1,29 @@
+PKGBUILD for graph-cli
+======================
+
+Description of graph-cli from its website
+(https://github.com/mcastorina/graph-cli)A:
+
+ A CLI utility to create graphs from CSV files.
+
+ graph-cli is designed to be highly configurable for easy and detailed graph
+ generation. It has many flags to acquire this detail and uses reasonable
+ defaults to avoid bothering the user. It also leverages chaining, so you can
+ create complex graphs from multiple CSV files.
+
+This repository only contains the PKGBUILD published on Arch User Repository.
+
+To install this package, run :
+
+```
+git clone https://github.com/mcastorina/graph-cli
+cd graph-cli
+makepkg
+```
+
+Or use an AUR helper :
+
+```
+yay -S graph-cli
+```
+