summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Kubaty2023-02-22 02:34:34 +0100
committerPiotr Kubaty2023-02-22 02:34:34 +0100
commitfaa4a41f6add82e230658701442ee61275b72739 (patch)
tree2f89fd90f88d7af48e64ce90fe3cfa8a1c158fa4
downloadaur-faa4a41f6add82e230658701442ee61275b72739.tar.gz
first publish
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6716daace20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = graph-editor-bin
+ pkgdesc = apk of graph-editor-for-android application, built from https://github.com/Student-Team-Projects/Graph-Editor-Android, https://github.com/Student-Team-Projects/Graph-Editor-Core
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Student-Team-Projects/Graph-Editor-Android-bin
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/Student-Team-Projects/Graph-Editor-Android-bin#branch=main
+ md5sums = SKIP
+
+pkgname = graph-editor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..542c28abfb60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Piotr Kubaty
+pkgname=graph-editor-bin
+pkgver=0.1
+pkgrel=1
+pkgdesc="apk of graph-editor-for-android application, built from https://github.com/Student-Team-Projects/Graph-Editor-Android, https://github.com/Student-Team-Projects/Graph-Editor-Core"
+arch=(x86_64)
+url="https://github.com/Student-Team-Projects/Graph-Editor-Android-bin"
+license=('GPL')
+makedepends=('git')
+source=("git+$url#branch=main")
+md5sums=('SKIP')
+
+build() {
+ cd "Graph-Editor-Android-bin"
+}
+
+package() {
+ cd "Graph-Editor-Android-bin"
+ adb install -t graph-editor-for-android.apk
+ adb shell am start -n "com.example.graph_editor/com.example.graph_editor.menu.MenuActivity" -a android.intent.action.MAIN -c android.intent.category.LAUNCHER
+}