summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nakhimovich2022-03-03 03:26:50 +0200
committerDaniel Nakhimovich2022-03-03 03:26:50 +0200
commit10cd37d991c93f27adf85c9d33a17e11123bbe8b (patch)
tree8cf5b8e1d9dfd7b617318c15945322490177be70
parent44e15281fee1fa85015696a0f7e8d91ee8c912df (diff)
downloadaur-10cd37d991c93f27adf85c9d33a17e11123bbe8b.tar.gz
update version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96a0e6177662..ad5e5fe9e642 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = graphblas
pkgdesc = A full implementation of the GraphBLAS standard (graphblas.org)
- pkgver = 3.0.1
- pkgrel = 3
- url = http://faculty.cse.tamu.edu/davis/GraphBLAS.html
+ pkgver = 6.2.2
+ pkgrel = 4
+ url = http://github.com/DrTimothyAldenDavis/GraphBLAS
arch = any
license = APACHE
makedepends = cmake
provides = graphblas
conflicts = graphblas
- source = http://faculty.cse.tamu.edu/davis/GraphBLAS/GraphBLAS-3.0.1.tar.gz
- sha256sums = 1f864b8ec7763001484b2220e5183a7fe2c09b73bf75b394ab5ea6b7a2e7f41a
+ source = https://github.com/DrTimothyAldenDavis/GraphBLAS/archive/refs/tags/v6.2.2.tar.gz
+ sha256sums = e146ac1b5b22394f912e303ce3c10c7a97dc628df78dedf5dca6c9f27ddef2d7
pkgname = graphblas
diff --git a/PKGBUILD b/PKGBUILD
index b1312bb8e0b4..96bfe29b4d85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: DanielNak <daniel@tee.cat>
# Library package author: Timothy A. Davis <Davis@tamu.edu>
-_author=davis
+_author=DrTimothyAldenDavis
_pkgname=GraphBLAS
pkgname=graphblas
-pkgver=3.0.1
-pkgrel=3
+pkgver=6.2.2
+pkgrel=4
pkgdesc="A full implementation of the GraphBLAS standard (graphblas.org)"
arch=('any')
-url="http://faculty.cse.tamu.edu/$_author/$_pkgname.html"
+url="http://github.com/$_author/$_pkgname"
license=('APACHE')
depends=()
makedepends=('cmake')
provides=("$pkgname")
conflicts=("$pkgname")
-source=("http://faculty.cse.tamu.edu/$_author/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('1f864b8ec7763001484b2220e5183a7fe2c09b73bf75b394ab5ea6b7a2e7f41a')
+# source=("http://faculty.cse.tamu.edu/$_author/$_pkgname/$_pkgname-$pkgver.tar.gz")
+source=("https://github.com/$_author/$_pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('e146ac1b5b22394f912e303ce3c10c7a97dc628df78dedf5dca6c9f27ddef2d7')
build() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$_pkgname-$pkgver"
(( NJOB=$(nproc)-1 )) || NJOB=1
make library JOBS=$NJOB CMAKE_OPTIONS=-DCMAKE_INSTALL_PREFIX=/usr
}
package(){
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$_pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
# install -Dm644 Doc/License.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
cd "$pkgdir/usr"