summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-11-25 13:27:01 +0300
committerorhun2020-11-25 13:27:01 +0300
commit43debc6488c1a983358da9ed22a55a128fa8ea13 (patch)
tree225ff78a8e31bc311044b797ee7d2ce10b285c75
parentfcd956f3adc0f6aafed50b6107b3ff8eb7062f4d (diff)
downloadaur-43debc6488c1a983358da9ed22a55a128fa8ea13.tar.gz
upgpkg: graphenex 1.3.1-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09cf0419d278..2113e170506e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = graphenex
pkgdesc = Automated System Hardening Framework
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/grapheneX/grapheneX
arch = x86_64
license = GPL3
makedepends = python-setuptools
+ makedepends = python-dephell
depends = python
- source = https://files.pythonhosted.org/packages/38/7f/902aa41f263e577ba5f75fe9d20a195181babec94e3f93c7fe858679b7f1/graphenex-1.3.1.tar.gz
+ depends = python-flask-socketio
+ depends = python-coloredlogs
+ depends = python-terminaltables
+ depends = python-pyinquirer
+ depends = python-psutil
+ depends = python-colorama
+ source = https://files.pythonhosted.org/packages/source/graphenex/graphenex/graphenex-1.3.1.tar.gz
md5sums = fd9d49d609083bc518d7412a1f5aa62f
pkgname = graphenex
diff --git a/PKGBUILD b/PKGBUILD
index 8c9456fea3c8..1e873840bf01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,32 @@
# https://github.com/orhun/pkgbuilds
pkgname=graphenex
-_pkgfolder=GrapheneX
+_pkgname=GrapheneX
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Automated System Hardening Framework"
url="https://github.com/grapheneX/grapheneX"
-depends=('python')
-makedepends=('python-setuptools')
+depends=('python' 'python-flask-socketio' 'python-coloredlogs'
+ 'python-terminaltables' 'python-pyinquirer' 'python-psutil'
+ 'python-colorama')
+makedepends=('python-setuptools' 'python-dephell')
license=('GPL3')
arch=('x86_64')
-source=("https://files.pythonhosted.org/packages/38/7f/902aa41f263e577ba5f75fe9d20a195181babec94e3f93c7fe858679b7f1/graphenex-1.3.1.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('fd9d49d609083bc518d7412a1f5aa62f')
+prepare() {
+ cd "$_pkgname-$pkgver"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
build() {
- cd "$_pkgfolder-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$_pkgfolder-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}