summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeyLo992019-07-18 16:30:42 +0300
committerKeyLo992019-07-18 16:30:42 +0300
commit97eac14440e74a1cd2a4b4eedeb9902d44f504e8 (patch)
treef366ef78b910fe2e962f0c9bd0bfc9a30319f599
downloadaur-97eac14440e74a1cd2a4b4eedeb9902d44f504e8.tar.gz
Release version 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3fd2e113e50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = graphenex
+ pkgdesc = Automated System Hardening Framework
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/grapheneX/grapheneX
+ arch = any
+ license = GPLv3
+ makedepends = python3
+ depends = python
+ source = https://files.pythonhosted.org/packages/9a/16/be0e710177751959f160d3f21c0d910cc9d0aa874d3550804d20ef96cedb/graphenex-1.0.0.tar.gz
+ md5sums = 7ab8702e516f69369d036a87b682d2a7
+
+pkgname = graphenex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04550e2cbd31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: GrapheneX Team <graphenex.project@protonmail.com>
+
+pkgname=graphenex
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Automated System Hardening Framework"
+url="https://github.com/grapheneX/grapheneX"
+depends=('python')
+makedepends=('python3')
+license=('GPLv3')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/9a/16/be0e710177751959f160d3f21c0d910cc9d0aa874d3550804d20ef96cedb/graphenex-1.0.0.tar.gz')
+md5sums=('7ab8702e516f69369d036a87b682d2a7')
+
+build() {
+ cd $srcdir/graphenex-1.0.0
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/graphenex-1.0.0
+ python setup.py install --root="$pkgdir" --optimize=1
+} \ No newline at end of file