summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2021-10-21 15:46:22 +0200
committeregnappahz2021-10-21 15:46:22 +0200
commit4eaad687feea4f4591e65b021575e2ea8f43b55e (patch)
treeb9bd5e13ce66da095ec5c3f97b6a5264b6b71830
downloadaur-4eaad687feea4f4591e65b021575e2ea8f43b55e.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD31
-rw-r--r--graphite-web.service21
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dd511064cd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = graphite-web
+ pkgdesc = Graphite-web, without the interface. Just the rendering HTTP API.
+ pkgver = 1.1.8
+ pkgrel = 1
+ url = https://github.com/graphite-project/graphite-web/
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-pytz
+ depends = python-six
+ depends = python-flask
+ depends = python-structlog
+ depends = python-yaml
+ depends = python-tzlocal
+ depends = python-cairocffi
+ depends = python-pyparsing
+ depends = python-django
+ optdepends = python-flask-cache: For caching
+ optdepends = python-raven: For sentry support
+ source = graphite-web-1.1.8.tar.gz::https://github.com/graphite-project/graphite-web/archive/1.1.8.tar.gz
+ source = graphite-web.service
+ sha256sums = SKIP
+ sha256sums = 12a8b2449f8a630d66ba37635caae520852936cc9b73adfb1e0985192aa2d522
+
+pkgname = graphite-web
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5666fd22f80e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Steven De Bondt <egnappah at gmail dot com>
+
+pkgname=graphite-web
+pkgver=1.1.8
+pkgrel=1
+pkgdesc="Graphite-web, without the interface. Just the rendering HTTP API."
+url="https://github.com/graphite-project/graphite-web/"
+license=('Apache')
+depends=('python-pytz' 'python-six' 'python-flask' 'python-structlog'
+ 'python-yaml' 'python-tzlocal' 'python-cairocffi' 'python-pyparsing'
+ 'python-django')
+makedepends=('python-setuptools')
+optdepends=('python-flask-cache: For caching'
+ 'python-raven: For sentry support')
+arch=('any')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/graphite-project/${pkgname}/archive/${pkgver}.tar.gz"
+ "graphite-web.service")
+sha256sums=('SKIP'
+ '12a8b2449f8a630d66ba37635caae520852936cc9b73adfb1e0985192aa2d522')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ mkdir -p "$pkgdir/var/lib/graphite"
+ install -Dm0644 "$srcdir/graphite-web.service" "$pkgdir/usr/lib/systemd/system/graphite-web.service"
+}
diff --git a/graphite-web.service b/graphite-web.service
new file mode 100644
index 000000000000..1853156e128a
--- /dev/null
+++ b/graphite-web.service
@@ -0,0 +1,21 @@
+[Unit]
+Description=Graphite-web daemon
+After=network.target
+
+[Service]
+Environment=PYTHONPATH=/opt/graphite/whisper
+ExecStart=/opt/graphite/bin/run-graphite-devel-server.py --libs=/opt/graphite/webapp/ /opt/graphite/
+Type=simple
+
+# some hardening
+PrivateTmp=true
+PrivateDevices=true
+ProtectSystem=full
+ProtectHome=true
+NoNewPrivileges=true
+CapabilityBoundingSet=
+ReadOnlyPaths=/
+
+[Install]
+WantedBy=multi-user.target
+