summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-05-07 11:35:11 -0700
committerclintval2018-05-07 11:35:11 -0700
commit0dc5b18bab52781b0ef061434582715c4ab47cad (patch)
treeefa69ebe989e12198e26c16535db916983a3fa24
downloadaur-0dc5b18bab52781b0ef061434582715c4ab47cad.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27f23733bca8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = graphpath
+ pkgdesc = Graphpath generates an ASCII network diagram from the route table of a Unix/Linux
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/alphabetum/graphpath
+ arch = any
+ license = BSD3
+ source = graphpath-1.0.tar.gz::https://github.com/ocochard/graphpath/archive/v1.0.tar.gz
+ sha256sums = 9e018bbb44f748595d4eb030896ccc195a9a75db773160da480743f31b5b8272
+
+pkgname = graphpath
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2137c82b0a08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=graphpath
+pkgver=1.0
+pkgrel=1
+pkgdesc='Graphpath generates an ASCII network diagram from the route table of a Unix/Linux router'
+arch=('any')
+url=https://github.com/alphabetum/"${pkgname}"
+license=('BSD3')
+source=("${pkgname}"-"${pkgver}".tar.gz::https://github.com/ocochard/"${pkgname}"/archive/v"${pkgver}".tar.gz)
+sha256sums=('9e018bbb44f748595d4eb030896ccc195a9a75db773160da480743f31b5b8272')
+
+package() {
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
+
+ install -Dm775 "${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
+ install -Dm644 README.md "${pkgdir}"/usr/share/doc/"${pkgname}"/README.md
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}