summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2018-02-19 02:38:37 +0100
committerkpcyrd2018-02-19 02:38:37 +0100
commit944039de22aec1d4eaa8f79a88ce8e3e6d65cde8 (patch)
tree3a24b9a792cc9aade28b14d9338b6692f7addc16
downloadaur-944039de22aec1d4eaa8f79a88ce8e3e6d65cde8.tar.gz
v0.1.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15a7845cc71e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = graphql-cli
+ pkgdesc = A command-line tool for working with graphql written in rust
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/tailhook/graphql-cli
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = aarch64
+ license = MIT
+ license = Apache
+ makedepends = cargo
+ depends = gcc-libs
+ source = https://github.com/tailhook/graphql-cli/archive/v0.1.0/graphql-cli-0.1.0.tar.gz
+ sha256sums = c296fbf0b5308f921eb4ee0f4201ccdcf5899cc38d89bd90559aca16190a1d69
+
+pkgname = graphql-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5790404272b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+
+pkgname=graphql-cli
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A command-line tool for working with graphql written in rust"
+url="https://github.com/tailhook/graphql-cli"
+depends=('gcc-libs')
+makedepends=('cargo')
+arch=('i686' 'x86_64' 'armv6h' 'aarch64')
+license=('MIT' 'Apache')
+source=("https://github.com/tailhook/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('c296fbf0b5308f921eb4ee0f4201ccdcf5899cc38d89bd90559aca16190a1d69')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/graphql" -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE-MIT LICENSE-APACHE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: