summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2018-10-23 13:31:27 -0400
committerWilliam Turner2018-10-23 13:31:27 -0400
commit588884a9f47a1beacd610a2103c9fba29e1dc948 (patch)
treee3b2f8df1b827c7bc79fce8b71beb5860989d3a1
downloadaur-588884a9f47a1beacd610a2103c9fba29e1dc948.tar.gz
Initial commit for 1.8.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58ed8ca9b26a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = graphql-playground-electron
+ pkgdesc = GraphQL IDE for better development workflows (GraphQL Subscriptions, interactive docs & collaboration).
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://github.com/prisma/graphql-playground
+ arch = x86_64
+ license = MIT
+ makedepends = sed
+ depends = gtk3
+ depends = gconf
+ depends = nss
+ depends = libxss
+ source = https://github.com/prisma/graphql-playground/releases/download/v1.8.0/graphql-playground-electron_1.8.0_amd64.deb
+ source = https://raw.githubusercontent.com/prisma/graphql-playground/v1.8.0/LICENSE
+ sha256sums = 000f5de344a280f7027c37d478d6ea3684a357333460fe2ad612baa2e1b22e4e
+ sha256sums = ee88d093c7c8e10dd41fc1c7b5ff51b2bbf57937b1b88eb3c1927f57743d59db
+
+pkgname = graphql-playground-electron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a570241fae79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=graphql-playground-electron
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="GraphQL IDE for better development workflows (GraphQL Subscriptions, interactive docs & collaboration)."
+arch=('x86_64')
+url="https://github.com/prisma/graphql-playground"
+license=('MIT')
+depends=('gtk3' 'gconf' 'nss' 'libxss')
+makedepends=('sed')
+source=("https://github.com/prisma/graphql-playground/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb"
+ "https://raw.githubusercontent.com/prisma/graphql-playground/v${pkgver}/LICENSE")
+sha256sums=('000f5de344a280f7027c37d478d6ea3684a357333460fe2ad612baa2e1b22e4e'
+ 'ee88d093c7c8e10dd41fc1c7b5ff51b2bbf57937b1b88eb3c1927f57743d59db')
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package() {
+ mv opt "$pkgdir"
+ mv usr "$pkgdir"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}