summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2020-10-05 23:00:41 +0200
committerDaniel Maslowski2020-10-05 23:00:41 +0200
commit3ba5902d4f781608ca3e0cb40e537ffc712faa83 (patch)
tree19b89571a6d36cf61c9b6158cc270ed90390989f
downloadaur-3ba5902d4f781608ca3e0cb40e537ffc712faa83.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
-rw-r--r--setup.py21
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..992b971dd261
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = graphqlmap-git
+ pkgdesc = scripting engine to interact with a GraphQL endpoint for pentesting purposes
+ pkgver = r44.87b5626
+ pkgrel = 1
+ url = https://github.com/swisskyrepo/GraphQLmap
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ depends = python-argparse
+ depends = python-requests
+ provides = graphqlmap
+ conflicts = graphqlmap
+ options = !emptydirs
+ source = git://github.com/swisskyrepo/graphqlmap.git
+ source = setup.py
+ sha512sums = SKIP
+ sha512sums = f8298ccecb9010627a80e12ae736ba2d7b4526bd668585cbc8a3cb1245866d1ea1d762e69511ce55c04824138f4c9bcaddf7c96149efd24f191ca06147633346
+
+pkgname = graphqlmap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75a5d9262bd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+
+_pyname=graphqlmap
+pkgname=graphqlmap-git
+pkgver=r44.87b5626
+pkgrel=1
+pkgdesc="scripting engine to interact with a GraphQL endpoint for pentesting purposes"
+arch=('any')
+url="https://github.com/swisskyrepo/GraphQLmap"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-setuptools'
+ 'python-argparse'
+ 'python-requests'
+)
+provides=("$_pyname")
+conflicts=(graphqlmap)
+options=(!emptydirs)
+source=(
+ git://github.com/swisskyrepo/$_pyname.git
+ setup.py
+)
+sha512sums=('SKIP'
+ 'f8298ccecb9010627a80e12ae736ba2d7b4526bd668585cbc8a3cb1245866d1ea1d762e69511ce55c04824138f4c9bcaddf7c96149efd24f191ca06147633346')
+
+pkgver() {
+ cd "$_pyname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pyname"
+ sed -i "s#from attacks#from graphqlmap.attacks#" graphqlmap.py
+ sed -i "s#from utils#from graphqlmap.utils#" attacks.py
+ mkdir bin
+ mv graphqlmap.py bin/graphqlmap
+ mkdir graphqlmap
+ mv *.py graphqlmap/
+ touch graphqlmap/__init__.py
+ mv ../setup.py .
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..d7eb9dafdfa9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+import setuptools
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+setuptools.setup(
+ name="graphqlmap",
+ version="0.0.1",
+ description="scripting engine to interact with a GraphQL endpoint for pentesting purposes",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://github.com/swisskyrepo/GraphQLmap",
+ packages=setuptools.find_packages(),
+ scripts=["bin/graphqlmap"],
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+ python_requires='>=3.6',
+)