summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-28 11:38:07 +1300
committercaltlgin2020-09-28 11:38:07 +1300
commit14b71f887d33fbd3559c6650700572fed77c0563 (patch)
tree6a2a397c83245b5d18c1dfcf0388b13892948e13
downloadaur-14b71f887d33fbd3559c6650700572fed77c0563.tar.gz
Add to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f972d0ea477
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = graphui
+ pkgdesc = Graph visualization based on graphviz with included text editor and preview area
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/artemanufrij/graphui
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ depends = gtksourceview3
+ source = graphui-1.1.1.tar.gz::https://github.com/artemanufrij/graphui/archive/1.1.1.tar.gz
+ sha256sums = 8520a394bbd2072aac2db03b1c3fa54d1f32459caafa85c9bc0fa43eadbe1a80
+
+pkgname = graphui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b101cc2a4e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='graphui'
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Graph visualization based on graphviz with included text editor and preview area'
+arch=('x86_64')
+url='https://github.com/artemanufrij/graphui'
+license=('GPL3')
+depends=('granite' 'gtksourceview3')
+makedepends=('meson' 'vala')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('8520a394bbd2072aac2db03b1c3fa54d1f32459caafa85c9bc0fa43eadbe1a80')
+
+build() {
+ arch-meson "${pkgname}-${pkgver}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}-${pkgver}/README.md"
+}
+
+# vim: ts=2 sw=2 et: