summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-28 11:41:11 +1300
committercaltlgin2020-09-28 11:41:11 +1300
commit402b3e6ea445b6bd8f1b6558fd3df8f69ccf109a (patch)
tree26e5e802c092751c6a64cb54f9678b22ed32bcf6
downloadaur-402b3e6ea445b6bd8f1b6558fd3df8f69ccf109a.tar.gz
Add to AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ec112ca4523
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = graphui-git
+ pkgdesc = Graph visualization based on graphviz with included text editor and preview area
+ pkgver = 1.1.1.r2.gb2e7cae
+ pkgrel = 1
+ url = https://github.com/artemanufrij/graphui
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ depends = gtksourceview3
+ provides = graphui
+ source = git+https://github.com/artemanufrij/graphui.git
+ sha256sums = SKIP
+
+pkgname = graphui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f98c2304f79c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='graphui'
+pkgname="${_pkgname}-git"
+pkgver=1.1.1.r2.gb2e7cae
+pkgrel=1
+pkgdesc='Graph visualization based on graphviz with included text editor and preview area'
+arch=('x86_64')
+url='https://github.com/artemanufrij/graphui'
+license=('GPL3')
+depends=('granite' 'gtksourceview3')
+makedepends=('git' 'meson' 'vala')
+provides=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${_pkgname}" build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" "${_pkgname}/README.md"
+}
+
+# vim: ts=2 sw=2 et: