summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Mielniczuk2017-10-23 12:53:44 +0200
committerMarcin Mielniczuk2017-10-23 12:53:44 +0200
commit7025001a462d2ce73f0d2166abb45a70ed4b5434 (patch)
tree719f0e662ee808db502da61c3be57b38a72c032b
downloadaur-7025001a462d2ce73f0d2166abb45a70ed4b5434.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c25a186aff8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = graphwar
+ pkgdesc = Hit your enemies using mathematical functions
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/catabriga/graphwar
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ makedepends = git
+ depends = java-runtime
+ source = git+https://github.com/catabriga/graphwar.git#tag=4c73cf71073acf64c26bc303e3896c7b250d82ba
+ sha1sums = SKIP
+
+pkgname = graphwar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95677e6a3632
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Marcin Mielniczuk <marmistrz.dev@zoho.eu>
+pkgname=graphwar
+pkgver=1.0
+pkgrel=1
+pkgdesc="Hit your enemies using mathematical functions"
+arch=(x86_64 i686)
+url="https://github.com/catabriga/graphwar"
+license=('GPLv3')
+depends=('java-runtime')
+makedepends=('git')
+source=("git+https://github.com/catabriga/graphwar.git#tag=4c73cf71073acf64c26bc303e3896c7b250d82ba")
+sha1sums=("SKIP")
+
+build() {
+ cd graphwar
+ make
+}
+
+package() {
+ cd graphwar
+ dest="$pkgdir/usr/share/games/graphwar/"
+ mkdir -p "$dest"
+ cp -r "graphwar.jar" "$dest"
+
+ mkdir -p "$pkgdir/usr/bin"
+ echo -e "#!/bin/sh\njava -jar /usr/share/games/graphwar/graphwar.jar" > "$pkgdir/usr/bin/graphwar"
+ chmod +x "$pkgdir/usr/bin/graphwar"
+}
+