summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2019-09-15 03:02:10 -0500
committerDoug Newgard2019-09-15 03:02:10 -0500
commit1f7ad43161674c2baab91dcd18ca692ec9ce023a (patch)
treede3efc43e9cb68292d5f91f3c1be0498d6ca8d9e
parent62588751dc761e7cc8a9f38b4d4320486e0087d1 (diff)
downloadaur-1f7ad43161674c2baab91dcd18ca692ec9ce023a.tar.gz
Upstream update to 7.8.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f58df3d47a7e..1fc02b1ac625 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grass
pkgdesc = Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization
- pkgver = 7.6.1
+ pkgver = 7.8.0
pkgrel = 1
url = http://grass.osgeo.org/
arch = i686
@@ -24,18 +24,17 @@ pkgbase = grass
depends = netcdf
depends = pdal
depends = proj
- depends = python2-gdal
- depends = python2-numpy
- depends = python2-pillow
+ depends = python-gdal
+ depends = python-numpy
+ depends = python-pillow
+ depends = python-wxpython
depends = readline
- depends = subversion
- depends = wxpython
depends = zlib
depends = zstd
optdepends = postgresql: PostgreSQL database interface
optdepends = sqlite: SQLite database interface
- source = http://grass.osgeo.org/grass76/source/grass-7.6.1.tar.gz
- md5sums = 9ca74f9010d013f735737a90c65d8a7f
+ source = http://grass.osgeo.org/grass78/source/grass-7.8.0.tar.gz
+ md5sums = e9b9d3bbbfe3ef9055ea1398b2222de4
pkgname = grass
diff --git a/PKGBUILD b/PKGBUILD
index e14a5e86f99d..d18e2832e353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maciej Sieczka <msieczka at sieczka dot org>
pkgname=grass
-pkgver=7.6.1
+pkgver=7.8.0
pkgrel=1
_shortver=${pkgver%.*}; _shortver=${_shortver/./}
pkgdesc='Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization'
@@ -10,22 +10,13 @@ arch=('i686' 'x86_64')
url='http://grass.osgeo.org/'
license=('GPL')
depends=('bzip2' 'cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos' 'glibc' 'glu'
- 'libpng' 'libtiff' 'libx11' 'libgl' 'netcdf' 'pdal' 'proj' 'python2-gdal' 'python2-numpy'
- 'python2-pillow' 'readline' 'subversion' 'wxpython' 'zlib' 'zstd')
+ 'libpng' 'libtiff' 'libx11' 'libgl' 'netcdf' 'pdal' 'proj' 'python-gdal' 'python-numpy'
+ 'python-pillow' 'python-wxpython' 'readline' 'zlib' 'zstd')
makedepends=('libxt')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz")
-md5sums=('9ca74f9010d013f735737a90c65d8a7f')
-
-prepare() {
- cd $pkgname-$pkgver
-
- # Change everything to use python2
- sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
- sed -i '/os\.environ.*GRASS_PYTHON/ s/"python"/"python2"/' lib/init/grass.py
- sed -i '/^PYTHON/ s/python$/&2/' include/Make/Platform.make.in
-}
+md5sums=('e9b9d3bbbfe3ef9055ea1398b2222de4')
build() {
cd $pkgname-$pkgver