summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkikislater2025-03-07 10:47:22 +0400
committerkikislater2025-03-07 10:47:22 +0400
commit397b5b96cd6317b51fd1bc913565953844c4ab26 (patch)
treed251dc6e823091a989edcd438ceaf026fe9d8c00
parent2ef9e9d0e88137fa5de2395a7d724aaf0d4bde0b (diff)
downloadaur-397b5b96cd6317b51fd1bc913565953844c4ab26.tar.gz
update to 8.4.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0dba5439652..2e3603e7187f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grass
pkgdesc = Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization
- pkgver = 8.4.0
- pkgrel = 2
+ pkgver = 8.4.1
+ pkgrel = 1
url = http://grass.osgeo.org/
arch = i686
arch = x86_64
@@ -34,7 +34,7 @@ pkgbase = grass
depends = zstd
optdepends = postgresql: PostgreSQL database interface
optdepends = sqlite: SQLite database interface
- source = grass-8.4.0.tar.gz::https://github.com/OSGeo/grass/archive/refs/heads/releasebranch_8_4.tar.gz
- sha256sums = SKIP
+ source = grass-8.4.1.tar.gz::https://github.com/OSGeo/grass/archive/refs/tags/8.4.1.tar.gz
+ sha256sums = 611e82dd919cd0e5c1a511e7efbc5c769e22ac6c613c3c4a2633c5d4b07c7e31
pkgname = grass
diff --git a/PKGBUILD b/PKGBUILD
index 790d56310194..c6c38653794c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Maciej Sieczka <msieczka at sieczka dot org>
pkgname=grass
-pkgver=8.4.0
-pkgrel=2
+pkgver=8.4.1
+pkgrel=1
_shortver=${pkgver%.*}; _shortver=${_shortver/./}
pkgdesc='Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization'
arch=('i686' 'x86_64')
@@ -16,13 +16,11 @@ depends=('bzip2' 'cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos
makedepends=('libxt' 'postgresql-libs')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/OSGeo/grass/archive/refs/heads/releasebranch_8_4.tar.gz"
-#"$pkgname-$pkgver.tar.gz::https://github.com/OSGeo/$pkgname/archive/refs/tags/$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/OSGeo/$pkgname/archive/refs/tags/$pkgver.tar.gz"
)
-sha256sums=('SKIP')
+sha256sums=('611e82dd919cd0e5c1a511e7efbc5c769e22ac6c613c3c4a2633c5d4b07c7e31')
build() {
- mv grass-releasebranch_8_4 $pkgname-$pkgver
cd $pkgname-$pkgver
# Ancient autoconf used upstream can't handle CPPFLAGS correctly, so set CPP to ignore warnings
@@ -42,7 +40,7 @@ build() {
--with-zstd
LC_ALL=C
- make
+ make -j1
}
package() {