summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2019-01-22 14:08:09 -0600
committerDoug Newgard2019-01-22 14:08:09 -0600
commit3d1783ae9c4d396e7d4b79a368382153c3142687 (patch)
tree5ed1328957c5aab089a9ca0ca8a1f588336d6413
parent0442201c5e198e0dc53c33a2f7161648b54ac856 (diff)
downloadaur-3d1783ae9c4d396e7d4b79a368382153c3142687.tar.gz
Upstream update to 7.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09393dba976a..da3c45b9cfb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grass
pkgdesc = Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization
- pkgver = 7.4.2
+ pkgver = 7.6.0
pkgrel = 1
url = http://grass.osgeo.org/
arch = i686
@@ -21,7 +21,9 @@ pkgbase = grass
depends = libx11
depends = libgl
depends = netcdf
+ depends = pdal
depends = proj
+ depends = python2-gdal
depends = python2-numpy
depends = python2-pillow
depends = readline
@@ -30,8 +32,8 @@ pkgbase = grass
depends = zlib
optdepends = postgresql: PostgreSQL database interface
optdepends = sqlite: SQLite database interface
- source = http://grass.osgeo.org/grass74/source/grass-7.4.2.tar.gz
- md5sums = bb3fc005e707f762c8fee36095e1df7f
+ source = http://grass.osgeo.org/grass76/source/grass-7.6.0.tar.gz
+ md5sums = 40f0b49529598cefd3e7b4f807d6133b
pkgname = grass
diff --git a/PKGBUILD b/PKGBUILD
index 53017eafcb54..8ffde3c874a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Maciej Sieczka <msieczka at sieczka dot org>
pkgname=grass
-pkgver=7.4.2
+pkgver=7.6.0
pkgrel=1
_shortver=${pkgver%.*}; _shortver=${_shortver/./}
pkgdesc='Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization'
@@ -10,13 +10,13 @@ arch=('i686' 'x86_64')
url='http://grass.osgeo.org/'
license=('GPL')
depends=('cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos' 'glibc' 'glu' 'libpng'
- 'libtiff' 'libx11' 'libgl' 'netcdf' 'proj' 'python2-numpy' 'python2-pillow' 'readline'
- 'subversion' 'wxpython' 'zlib')
+ 'libtiff' 'libx11' 'libgl' 'netcdf' 'pdal' 'proj' 'python2-gdal' 'python2-numpy'
+ 'python2-pillow' 'readline' 'subversion' 'wxpython' 'zlib')
makedepends=('libxt')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz")
-md5sums=('bb3fc005e707f762c8fee36095e1df7f')
+md5sums=('40f0b49529598cefd3e7b4f807d6133b')
prepare() {
cd $pkgname-$pkgver
@@ -25,16 +25,11 @@ prepare() {
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")
sed -i '/os\.environ.*GRASS_PYTHON/ s/"python"/"python2"/' lib/init/grass.py
sed -i '/^PYTHON/ s/python$/&2/' include/Make/Platform.make.in
-
- # Fix path
- sed -i '/^\s*INSTDIR/ s/".*"//' configure
}
build() {
cd $pkgname-$pkgver
- export CXXFLAGS="-std=c++98 $CXXFLAGS"
-
# Ancient autoconf used upstream can't handle CPPFLAGS correctly, so set CPP to ignore warnings
CPP="gcc -E -w" \
./configure \
@@ -46,7 +41,8 @@ build() {
--with-netcdf \
--with-nls \
--with-geos \
- --with-postgres
+ --with-postgres \
+ --with-pdal
make
}
@@ -73,5 +69,4 @@ package() {
include/Make/{Platform,Grass}.make \
etc/fontcap \
"$pkgdir/usr/bin/grass$_shortver"
- sed -i "s|$srcdir||g" docs/html/t.connect.html
}