summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2019-07-22 08:50:24 -0500
committerDoug Newgard2019-07-22 08:50:24 -0500
commit62588751dc761e7cc8a9f38b4d4320486e0087d1 (patch)
tree2bf51e9ee680ffdaf9fb23427b3f36d7200fb2ae
parent3d1783ae9c4d396e7d4b79a368382153c3142687 (diff)
downloadaur-62588751dc761e7cc8a9f38b4d4320486e0087d1.tar.gz
Upstream update to 7.6.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3c45b9cfb4..f58df3d47a7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = grass
pkgdesc = Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization
- pkgver = 7.6.0
+ pkgver = 7.6.1
pkgrel = 1
url = http://grass.osgeo.org/
arch = i686
arch = x86_64
license = GPL
makedepends = libxt
+ depends = bzip2
depends = cairo
depends = fftw
depends = fontconfig
@@ -30,10 +31,11 @@ pkgbase = grass
depends = subversion
depends = wxpython
depends = zlib
+ depends = zstd
optdepends = postgresql: PostgreSQL database interface
optdepends = sqlite: SQLite database interface
- source = http://grass.osgeo.org/grass76/source/grass-7.6.0.tar.gz
- md5sums = 40f0b49529598cefd3e7b4f807d6133b
+ source = http://grass.osgeo.org/grass76/source/grass-7.6.1.tar.gz
+ md5sums = 9ca74f9010d013f735737a90c65d8a7f
pkgname = grass
diff --git a/PKGBUILD b/PKGBUILD
index 8ffde3c874a8..e14a5e86f99d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Contributor: Maciej Sieczka <msieczka at sieczka dot org>
pkgname=grass
-pkgver=7.6.0
+pkgver=7.6.1
pkgrel=1
_shortver=${pkgver%.*}; _shortver=${_shortver/./}
pkgdesc='Geospatial data management and analysis, image processing, graphics/maps production, spatial modeling and visualization'
arch=('i686' 'x86_64')
url='http://grass.osgeo.org/'
license=('GPL')
-depends=('cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos' 'glibc' 'glu' 'libpng'
- 'libtiff' 'libx11' 'libgl' 'netcdf' 'pdal' 'proj' 'python2-gdal' 'python2-numpy'
- 'python2-pillow' 'readline' 'subversion' 'wxpython' 'zlib')
+depends=('bzip2' 'cairo' 'fftw' 'fontconfig' 'freetype2' 'gcc-libs' 'gdal' 'geos' 'glibc' 'glu'
+ 'libpng' 'libtiff' 'libx11' 'libgl' 'netcdf' 'pdal' 'proj' 'python2-gdal' 'python2-numpy'
+ 'python2-pillow' 'readline' 'subversion' 'wxpython' 'zlib' 'zstd')
makedepends=('libxt')
optdepends=('postgresql: PostgreSQL database interface'
'sqlite: SQLite database interface')
source=("http://grass.osgeo.org/grass$_shortver/source/$pkgname-$pkgver.tar.gz")
-md5sums=('40f0b49529598cefd3e7b4f807d6133b')
+md5sums=('9ca74f9010d013f735737a90c65d8a7f')
prepare() {
cd $pkgname-$pkgver
@@ -42,7 +42,9 @@ build() {
--with-nls \
--with-geos \
--with-postgres \
- --with-pdal
+ --with-pdal \
+ --with-bzlib \
+ --with-zstd
make
}