summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2016-04-11 23:43:01 -0500
committerDoug Newgard2016-04-11 23:43:01 -0500
commit8bba795acd245cd7d1b178a7fd82addaa4e03f8d (patch)
tree92f27e50c24b0953eecd8b8033f6e76a8d77377e
parent52ab3cba082e68b92d95754764cf0cc5478cbeb4 (diff)
downloadaur-8bba795acd245cd7d1b178a7fd82addaa4e03f8d.tar.gz
Simpler CPPFLAGS workaround
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02977707509c..c76578a057b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,11 +31,8 @@ prepare() {
build() {
cd $pkgname-$pkgver
- # Ancient autoconf used upstream can't handle CPPFLAGS correctly
- export CFLAGS="$CPPFLAGS $CFLAGS"
- export CXXFLAGS="$CPPFLAGS $CXXFLAGS"
- unset CPPFLAGS
-
+ # Ancient autoconf used upstream can't handle CPPFLAGS correctly, so set CPP to ignore warnings
+ CPP="gcc -E -w" \
./configure \
--prefix=/opt/$pkgname \
--with-freetype-includes=/usr/include/freetype2 \