summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-25 20:31:45 +0300
committerDimitris Kiziridis2020-04-25 20:31:45 +0300
commit490eda0c57505dc0eae5ac5e396b7884ab07c0e2 (patch)
treee45e7fa3457dc2a5b6cbe7a34e0bf0fbdfef6e64
parent9f90b8a8d8beef32beedb7f5cebc8f795dd9843d (diff)
downloadaur-490eda0c57505dc0eae5ac5e396b7884ab07c0e2.tar.gz
Update to 1.7.0-rc.8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD36
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c31063f95826..33b174a10704 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grav
pkgdesc = Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS (without Admin plugin)
- pkgver = 1.6.22
+ pkgver = 1.7.0.rc.8
pkgrel = 1
url = https://getgrav.org
install = grav.install
@@ -8,14 +8,14 @@ pkgbase = grav
license = MIT
depends = php>=7.1.3
depends = php-gd
- depends = php-fpm
optdepends = php-apcu: A userland caching module for PHP
optdepends = xdebug: PHP debugging extension
optdepends = apache: A high performance Unix-based HTTP server
optdepends = nginx: Lightweight HTTP server and IMAP/POP3 proxy server
+ optdepends = php-fpm: FastCGI Process Manager
provides = grav
- source = https://github.com/getgrav/grav/releases/download/1.6.22/grav-v1.6.22.zip
- sha256sums = e3c84bb2a7a35dea3c0f430f097498e560074da9cfe9d89418a24b7b4f3a4072
+ source = https://github.com/getgrav/grav/archive/1.7.0-rc.8/grav-v1.7.0-rc.8.zip
+ sha256sums = 39f96f910e224544c4f898788b4dabb85bd69b951d68f3618069fb8daefda481
pkgname = grav
diff --git a/PKGBUILD b/PKGBUILD
index 5e8cba8f17b1..33ed94cbd4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,34 @@
# Contributor: Nils Czernia <nils[at]czserver[dot[de>
pkgname=grav
-pkgver=1.6.22
+pkgver=1.7.0.rc.8
pkgrel=1
pkgdesc="Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS (without Admin plugin)"
arch=("any")
url="https://getgrav.org"
license=("MIT")
provides=('grav')
-depends=('php>=7.1.3' 'php-gd' 'php-fpm')
+depends=('php>=7.1.3' 'php-gd')
optdepends=('php-apcu: A userland caching module for PHP'
'xdebug: PHP debugging extension'
'apache: A high performance Unix-based HTTP server'
- 'nginx: Lightweight HTTP server and IMAP/POP3 proxy server')
+ 'nginx: Lightweight HTTP server and IMAP/POP3 proxy server'
+ 'php-fpm: FastCGI Process Manager')
install=grav.install
-source=("https://github.com/getgrav/grav/releases/download/${pkgver}/${pkgname}-v${pkgver}.zip")
-sha256sums=('e3c84bb2a7a35dea3c0f430f097498e560074da9cfe9d89418a24b7b4f3a4072')
+source=("https://github.com/getgrav/grav/archive/${pkgver:0:5}-${pkgver:6}/${pkgname}-v${pkgver:0:5}-${pkgver:6}.zip")
+sha256sums=('39f96f910e224544c4f898788b4dabb85bd69b951d68f3618069fb8daefda481')
package() {
- cd "${pkgdir}"
- install -dm0755 usr/share/webapps/${pkgname}
- mv ${srcdir}/${pkgname} ${pkgdir}/usr/share/webapps/
- cd ${pkgdir}/usr/share/webapps/${pkgname}
- chgrp -R http .
- find . -type f | xargs chmod 664
- find ./bin -type f | xargs chmod 775
- find . -type d | xargs chmod 775
- find . -type d | xargs chmod +s
- umask 0002
- rm -Rf *.md composer.json composer.lock
-}
+ cd "${pkgdir}"
+ install -dm0755 usr/share/webapps/
+ mv ${srcdir}/${pkgname}-${pkgver:0:5}-${pkgver:6} ${pkgdir}/usr/share/webapps/${pkgname}
+ cd ${pkgdir}/usr/share/webapps/${pkgname}
+ chgrp -R http .
+ find . -type f | xargs chmod 664
+ find ./bin -type f | xargs chmod 775
+ find . -type d | xargs chmod 775
+ find . -type d | xargs chmod +s
+ umask 0002
+ rm -Rf *.md composer.json composer.lock .github
+ rm $(find . -type f -name .gitkeep | xargs)
+} \ No newline at end of file