summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-12 21:08:15 +0200
committerDimitris Kiziridis2020-03-12 21:08:15 +0200
commit6b019defc5da0f3980e9a558e3faa7ab5883328c (patch)
tree67775685dac371ea37ebf0efcb26da888cb25cfb
downloadaur-6b019defc5da0f3980e9a558e3faa7ab5883328c.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD35
-rw-r--r--post_install6
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfada4bfa104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = grav
+ pkgdesc = Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS (without Admin plugin)
+ pkgver = 1.6.22
+ pkgrel = 1
+ url = https://getgrav.org
+ install = post_install
+ arch = any
+ license = MIT
+ depends = php>=7.1.3
+ depends = php-gd
+ depends = php-fpm
+ optdepends = php-apcu: A userland caching module for PHP
+ optdepends = xdebug: PHP debugging extension
+ optdepends = apache: A high performance Unix-based HTTP server
+ optdepends = nginx: Lightweight HTTP server and IMAP/POP3 proxy server
+ provides = grav
+ source = https://github.com/getgrav/grav/releases/download/1.6.22/grav-v1.6.22.zip
+ source = post_install
+ sha256sums = e3c84bb2a7a35dea3c0f430f097498e560074da9cfe9d89418a24b7b4f3a4072
+ sha256sums = 96ae16816f0032c12d45e7fa912ec275e8ca6735aef6e0d7e7fe5e30d36181ab
+
+pkgname = grav
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1637f4064df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Nils Czernia <nils[at]czserver[dot[de>
+
+pkgname=grav
+pkgver=1.6.22
+pkgrel=1
+pkgdesc="Modern, Crazy Fast, Ridiculously Easy and Amazingly Powerful Flat-File CMS (without Admin plugin)"
+arch=("any")
+url="https://getgrav.org"
+license=("MIT")
+provides=('grav')
+depends=('php>=7.1.3' 'php-gd' 'php-fpm')
+optdepends=('php-apcu: A userland caching module for PHP'
+ 'xdebug: PHP debugging extension'
+ 'apache: A high performance Unix-based HTTP server'
+ 'nginx: Lightweight HTTP server and IMAP/POP3 proxy server')
+install=post_install
+source=("https://github.com/getgrav/grav/releases/download/${pkgver}/${pkgname}-v${pkgver}.zip"
+ 'post_install')
+sha256sums=('e3c84bb2a7a35dea3c0f430f097498e560074da9cfe9d89418a24b7b4f3a4072'
+ '96ae16816f0032c12d45e7fa912ec275e8ca6735aef6e0d7e7fe5e30d36181ab')
+
+package() {
+ cd "${pkgdir}"
+ install -dm0755 usr/share/webapps/${pkgname}
+ mv ${srcdir}/${pkgname} ${pkgdir}/usr/share/webapps/
+ cd ${pkgdir}/usr/share/webapps/${pkgname}
+ chgrp -R http .
+ find . -type f | xargs chmod 664
+ find ./bin -type f | xargs chmod 775
+ find . -type d | xargs chmod 775
+ find . -type d | xargs chmod +s
+ umask 0002
+ rm -Rf *.md composer.json composer.lock
+}
diff --git a/post_install b/post_install
new file mode 100644
index 000000000000..2b7d7ad857a7
--- /dev/null
+++ b/post_install
@@ -0,0 +1,6 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+post_install() {
+ echo -e "This package assumes you're running your webserver under '\e[32mhttp\e[37m' username"
+ echo -e "If not, modify the script accordingly, by replacing '\e[32mhttp\e[37m' with the username you're running your webserver under."
+} \ No newline at end of file