summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpider.007 / Sjon2020-02-04 15:06:01 +0100
committerSpider.007 / Sjon2020-02-04 15:06:46 +0100
commitae1e46f53a1e9a61a830e0a4527dfa3d234b9364 (patch)
tree2fb40a7adf979204c9f38a01f34ef541f3d26246
parentb28aa502a207cdbcf1a4bbff8eae35d9ed4925ba (diff)
downloadaur-ae1e46f53a1e9a61a830e0a4527dfa3d234b9364.tar.gz
upgrade to 3.2.0 - include changelog
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--UPGRADING.rst66
3 files changed, 78 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ef07bc12d8a..93bf72dda4dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = graylog
pkgdesc = Graylog is an open source syslog implementation that stores your logs in ElasticSearch and MongoDB
- pkgver = 3.1.4
+ pkgver = 3.2.0
pkgrel = 1
url = https://www.graylog.org/
install = graylog.install
+ changelog = UPGRADING.rst
arch = any
license = GPL
depends = java-runtime-headless=8
optdepends = elasticsearch
optdepends = mongodb
backup = etc/graylog/server/server.conf
- source = https://packages.graylog2.org/releases/graylog/graylog-3.1.4.tgz
+ source = https://packages.graylog2.org/releases/graylog/graylog-3.2.0.tgz
source = graylog-tmpfiles.conf
source = graylog.service
- sha256sums = dc49be8d915a4b0542743719d9dd3183864b3497c09fc56af78296d904f2f2fc
+ sha256sums = 3f65c219a510d4ee61ddf6cf999d44e3f46b455c5fcdd9b754c1b753c5a41089
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9269481d3d8b..ed6544f6285e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Spider.007 <aur@spider007.net>
pkgname=graylog
-pkgver=3.1.4
+pkgver=3.2.0
pkgrel=1
pkgdesc="Graylog is an open source syslog implementation that stores your logs in ElasticSearch and MongoDB"
arch=('any')
@@ -9,6 +9,7 @@ license=(GPL)
depends=('java-runtime-headless=8')
optdepends=('elasticsearch' mongodb)
install=graylog.install
+changelog=UPGRADING.rst
backup=(
etc/graylog/server/server.conf
)
@@ -17,10 +18,15 @@ source=(
graylog-tmpfiles.conf
graylog.service
)
-sha256sums=('dc49be8d915a4b0542743719d9dd3183864b3497c09fc56af78296d904f2f2fc'
+
+sha256sums=('3f65c219a510d4ee61ddf6cf999d44e3f46b455c5fcdd9b754c1b753c5a41089'
'SKIP'
'SKIP')
+prepare() {
+ curl -O https://raw.githubusercontent.com/Graylog2/graylog2-server/3.2/UPGRADING.rst
+}
+
package() {
cd "$pkgdir"
diff --git a/UPGRADING.rst b/UPGRADING.rst
new file mode 100644
index 000000000000..0f6c6b9729c4
--- /dev/null
+++ b/UPGRADING.rst
@@ -0,0 +1,66 @@
+**************************
+Upgrading to Graylog 3.2.x
+**************************
+
+.. _upgrade-from-30-to-32:
+
+.. note:: Graylog 3.2.0 comes with a number of migrations that change parts of your existing data fundamentally. Please make sure to have a recent backup of your MongoDB that you can rollback to, before attempting to upgrade from an earlier version.
+
+Migrating Dashboards
+====================
+
+Graylog 3.2 contains a massive overhaul of its dashboarding functionality, which comes with a different data structure for them. Therefore, when running Graylog 3.2 for the first time, existing dashboards are being migrated. We try to keep them the same way as before, with a few exceptions:
+
+ * Quickvalues widgets configured to show both a pie chart and a data table are split up into two different widgets
+ * Stacked Charts containing multiple series with different queries are split up by query. If a stacked chart contains 5 series, 3 with query "foo", 2 with query "bar, it is split up into two widgets, one containing all 3 "foo"-series, the other containing the 2 "bar"-series.
+ * Widgets created using 3rd party plugins are migrated with their config, but unless the plugin author creates a corresponding plugin for 3.2, a placeholder is shown.
+
+Changed Default TLS Protocols
+=============================
+
+Graylog 3.2 will ship with a secure default of supported TLS protocols.
+This means that TLS 1.0 and TLS 1.1 won't be supported anymore. The new default setting affects all TLS enabled services such as message inputs or the graylog web interface.
+If needed, you can re-enable old TLS protocols with the newly introduced ``enabled_tls_protocols`` setting.
+
+Indexing Requests use HTTP Expect: 100-Continue Header
+======================================================
+
+Messages indexing requests to Elasticsearch are now executed with a HTTP Expect-Continue header.
+For the unlikely case that this is creating problems, it can be disabled using the newly introduced ``elasticsearch_use_expect_continue`` setting.
+
+Accounted Message Size Field
+============================
+
+Every message now includes the ``gl2_accounted_message_size`` field. To make sure this field will be created with the correct data type in all active write indices, the mapping of these indices needs to be updated. New indices created by index rotation will automatically have the correct mapping because the index template got updated automatically.
+
+.. warning:: The following steps need to be executed **before** starting the server with the 3.2.0 version!
+
+All of the following commands need to be executed against one of the Elasticsearch servers in the cluster.
+
+First, a list of all active write indices is needed::
+
+ curl -s localhost:9200/_cat/aliases/*_deflector?h=index
+
+For each of the index names returned by the previous command, the following command needs to be executed (``<active-write-index-name>`` in the URL needs to be replaced with the actual index name)::
+
+ curl -s -X PUT --data '{"properties":{"gl2_accounted_message_size":{"type": "long"}}}' -H Content-Type:application/json localhost:9200/<active-write-index-name>/_mapping/message
+
+The two steps could also be combined::
+
+ for index in `curl -s localhost:9200/_cat/aliases/*_deflector?h=index`; do curl -s -X PUT --data '{"properties":{"gl2_accounted_message_size":{"type": "long"}}}' -H Content-Type:application/json localhost:9200/$index/_mapping/message ; done'
+
+The Graylog servers can now be restarted with the 3.2.0 version.
+
+Known Bugs and Limitations
+==========================
+
+ * Content Packs containing old Dashbords can not be installed in Graylog 3.2.
+ * Some functionality of the search has been removed, namely:
+ * Retrieving the full query that is sent to Elasticsearch.
+ * Retrieving the list of terms a message field value was indexed with.
+ * The list of indices the current search used to generate results.
+ * The count of all received messages displayed next to the search.
+ We will add the count again, once the calculation works as expected.
+ As a workaround a message count widget can be added to the search.
+ * The "Show surrounding messages" action is not part of 3.2.0, but will be reimplemented in a next version.
+