summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Tremesaygues2020-11-13 19:51:36 +0100
committerJonathan Tremesaygues2020-11-13 19:51:36 +0100
commit763e207379c12a86e0aadf76e906da08bd864a71 (patch)
tree74568a8e12b43811f4d5329103be6d0d79babc64
parent45bc5031dd0d14af5eeafc5e1ba20185adab76f6 (diff)
downloadaur-763e207379c12a86e0aadf76e906da08bd864a71.tar.gz
fix compilation error
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bcbc4a118dd..12606a377989 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = graywolf-git
pkgdesc = An opensource placement tool
pkgver = 0.1.6.r184.6c5e24f
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/rubund/graywolf/
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 10318749fe85..91d26b7f3b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=graywolf-git
pkgver=0.1.6.r184.6c5e24f
-pkgrel=4
+pkgrel=5
epoch=
pkgdesc='An opensource placement tool'
arch=('i686' 'x86_64')
@@ -22,7 +22,13 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build
+ # Define C_FLAGS and CXX_FLAGS for ignoring a problem with global
+ # variables
+ # See https://github.com/rubund/graywolf/issues/43
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS="-fcommon" \
+ -DCMAKE_CXX_FLAGS="-fcommon" \
+ -B build
cmake --build build
}