diff options
author | Jonathan Tremesaygues | 2020-11-13 19:51:36 +0100 |
---|---|---|
committer | Jonathan Tremesaygues | 2020-11-13 19:51:36 +0100 |
commit | 763e207379c12a86e0aadf76e906da08bd864a71 (patch) | |
tree | 74568a8e12b43811f4d5329103be6d0d79babc64 | |
parent | 45bc5031dd0d14af5eeafc5e1ba20185adab76f6 (diff) | |
download | aur-763e207379c12a86e0aadf76e906da08bd864a71.tar.gz |
fix compilation error
-rw-r--r-- | .SRCINFO | 2 | ||||
-rw-r--r-- | .gitignore | 4 | ||||
-rw-r--r-- | PKGBUILD | 10 |
3 files changed, 13 insertions, 3 deletions
@@ -1,7 +1,7 @@ pkgbase = graywolf-git pkgdesc = An opensource placement tool pkgver = 0.1.6.r184.6c5e24f - pkgrel = 4 + pkgrel = 5 url = https://github.com/rubund/graywolf/ arch = i686 arch = x86_64 diff --git a/.gitignore b/.gitignore new file mode 100644 index 000000000000..4367ae4a50ac --- /dev/null +++ b/.gitignore @@ -0,0 +1,4 @@ +* +!.gitignore +!.SRCINFO +!PKGBUILD
\ No newline at end of file @@ -2,7 +2,7 @@ pkgname=graywolf-git pkgver=0.1.6.r184.6c5e24f -pkgrel=4 +pkgrel=5 epoch= pkgdesc='An opensource placement tool' arch=('i686' 'x86_64') @@ -22,7 +22,13 @@ pkgver() { build() { cd "${srcdir}/${pkgname%-git}" - cmake -DCMAKE_INSTALL_PREFIX=/usr -B build + # Define C_FLAGS and CXX_FLAGS for ignoring a problem with global + # variables + # See https://github.com/rubund/graywolf/issues/43 + cmake -DCMAKE_INSTALL_PREFIX=/usr \ + -DCMAKE_C_FLAGS="-fcommon" \ + -DCMAKE_CXX_FLAGS="-fcommon" \ + -B build cmake --build build } |