summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-22 23:46:13 +0300
committerDimitris Kiziridis2020-06-22 23:46:13 +0300
commitaceb0b45bf0694b71002afd4550ae885ba4c623f (patch)
treee39876ea92bd231ad10d15648f18b52e9a89396f
downloadaur-aceb0b45bf0694b71002afd4550ae885ba4c623f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdf83d2b8486
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = green-tunnel-bin
+ pkgdesc = An anti-censorship utility designed to bypass the DPI system that is put in place by various ISPs to block access to certain websites
+ pkgver = 1.7.4
+ pkgrel = 1
+ url = https://github.com/SadeghHayeri/GreenTunnel
+ arch = x86_64
+ license = MIT
+ makedepends = tar
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ source = green-tunnel-bin-1.7.4.zip::https://github.com/SadeghHayeri/GreenTunnel/releases/download/v1.7.4/green-tunnel-debian.zip
+ sha256sums = 9b7da96908ead5252f233713c16967ddcc3a6eff0282a43cf91e5e623c596b6c
+
+pkgname = green-tunnel-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae8a990249bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=green-tunnel-bin
+pkgver=1.7.4
+pkgrel=1
+pkgdesc='An anti-censorship utility designed to bypass the DPI system that is put in place by various ISPs to block access to certain websites'
+arch=('x86_64')
+url="https://github.com/SadeghHayeri/GreenTunnel"
+license=('MIT')
+depends=('nss'
+ 'gtk3'
+ 'libxss')
+makedepends=('tar')
+source=("${pkgname}-${pkgver}.zip::https://github.com/SadeghHayeri/GreenTunnel/releases/download/v${pkgver}/green-tunnel-debian.zip")
+sha256sums=('9b7da96908ead5252f233713c16967ddcc3a6eff0282a43cf91e5e623c596b6c')
+
+package() {
+ ar x green-tunnel_${pkgver}_amd64.deb
+ tar xvf data.tar.xz -C "${pkgdir}/"
+ install -Dm644 "${pkgdir}/usr/share/doc/green-tunnel/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -rf "${pkgdir}/usr/share/doc/"
+} \ No newline at end of file