summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2023-03-07 17:15:53 -0500
committerMithicSpirit2023-03-07 17:15:53 -0500
commit8774bee21c186a3b588681d0747f42e9c2c3e030 (patch)
tree3cfe5dad0e6007af964913e58ee7c5d10b5fbb7c
parenta443a2593fc66a0bfff396ce0e41b7a68ab5e93d (diff)
downloadaur-8774bee21c186a3b588681d0747f42e9c2c3e030.tar.gz
Initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD58
3 files changed, 58 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67fc86091a5b..f7deff83b34f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
pkgbase = greenclip
- pkgdesc = Clipboard manager to use with rofi
- pkgver = 2.1
- pkgrel = 0
- epoch = 0
- url = https://github.com/erebe/greenclip
- changelog = changelog
+ pkgdesc = Simple clipboard manager to be integrated with rofi
+ pkgver = 4.1.0
+ pkgrel = 2
+ url = https://github.com/erebe/greenclip#readme
arch = x86_64
- license = GPL
- depends = rofi
- provides = greenclip
- options = !strip
- source = https://github.com/erebe/greenclip/releases/download/2.1/greenclip
- sha256sums = 9964a6520f3ec6c935e3f6ef4b4b6235d79aab38060305673a66a5c71e7c9e57
+ license = BSD
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-x11
+ depends = haskell-hashable
+ depends = haskell-microlens
+ depends = haskell-microlens-mtl
+ depends = haskell-protolude
+ depends = haskell-tomland
+ depends = haskell-vector
+ depends = haskell-wordexp
+ provides = rofi-greenclip
+ conflicts = rofi-greenclip
+ source = greenclip-4.1.0.tar.gz::https://hackage.haskell.org/packages/archive/greenclip/4.1.0/greenclip-4.1.0.tar.gz
+ sha256sums = c41a4b6f17d250ec9bfe811d233701490d4efefd9cca3534a52e02379673a2fc
pkgname = greenclip
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..167d5c3bc3e7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index be1a7ece87b9..0800c8b68ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,40 @@
-# Maintainer: Romain GERARD <erebe@erebe.eu>
+# Maintainer: MithicSpirit <rpc01234 at gmail dot com>
pkgname=greenclip
-pkgver=2.1
-epoch=0
-pkgrel=0
-pkgdesc="Clipboard manager to use with rofi"
+pkgver=4.1.0
+pkgrel=2
+pkgdesc='Simple clipboard manager to be integrated with rofi'
+url='https://github.com/erebe/greenclip#readme'
+license=('BSD')
arch=('x86_64')
-url="https://github.com/erebe/greenclip"
-license=('GPL')
-groups=()
-depends=('rofi')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=("greenclip")
-conflicts=()
-replaces=()
-backup=()
-options=('!strip')
-install=
-changelog=changelog
-source=("https://github.com/erebe/greenclip/releases/download/2.1/greenclip")
-noextract=()
-sha256sums=("9964a6520f3ec6c935e3f6ef4b4b6235d79aab38060305673a66a5c71e7c9e57")
+depends=('ghc-libs' 'haskell-x11' 'haskell-hashable' 'haskell-microlens' 'haskell-microlens-mtl' 'haskell-protolude' 'haskell-tomland' 'haskell-vector' 'haskell-wordexp')
+conflicts=('rofi-greenclip')
+provides=('rofi-greenclip')
+makedepends=('ghc')
+source=("$pkgname-$pkgver.tar.gz::https://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('c41a4b6f17d250ec9bfe811d233701490d4efefd9cca3534a52e02379673a2fc')
-package() {
- install -Dm 755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ printf "import Distribution.Simple\nmain = defaultMain" >>Setup.hs
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}