summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2015-06-08 14:57:57 +0200
committerPier Luigi Fiorini2015-06-08 14:57:57 +0200
commitf613f879e0d2a73154c219dd6b74d8b6410df9aa (patch)
treed669c51a27355665e5c9cb9c60848caff9bedb36
downloadaur-f613f879e0d2a73154c219dd6b74d8b6410df9aa.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD48
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cca78b2774d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = greenisland-git
+ pkgdesc = Green Island: Qt-based compositor infrastructure for Wayland
+ pkgver = 20150517.98c424c
+ pkgrel = 1
+ url = https://github.com/greenisland/greenisland.git
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL,
+ license = LGPL
+ makedepends = git
+ makedepends = gdb
+ makedepends = extra-cmake-modules
+ depends = qt5-declarative
+ depends = hawaii-qt5-wayland-git
+ depends = xkeyboard-config
+ provides = greenisland
+ conflicts = greenisland
+ replaces = greenisland
+ options = debug
+ source = greenisland::git://github.com/greenisland/greenisland.git#branch=master
+ md5sums = SKIP
+
+pkgname = greenisland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59a6f23e4d76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=greenisland-git
+pkgver=20150517.98c424c
+pkgrel=1
+pkgdesc="Green Island: Qt-based compositor infrastructure for Wayland"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://github.com/greenisland/greenisland.git'
+license=('GPL', 'LGPL')
+depends=('qt5-declarative' 'hawaii-qt5-wayland-git' 'xkeyboard-config')
+provides=('greenisland')
+conflicts=('greenisland')
+replaces=('greenisland')
+makedepends=('git' 'gdb' 'extra-cmake-modules')
+options=('debug')
+
+_gitroot="git://github.com/greenisland/greenisland.git"
+_gitbranch=master
+_gitname=greenisland
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../${_gitname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DLIBEXEC_INSTALL_DIR=lib \
+ -DQML_INSTALL_DIR=lib/qt/qml \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DQtWaylandScanner_EXECUTABLE=/usr/lib/qt/bin/qtwaylandscanner \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}