summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony VanBerkum2015-06-08 17:48:54 -0400
committerAnthony VanBerkum2015-06-08 17:48:54 -0400
commit485288e083a0369144477884904d588d6a903361 (patch)
tree89b4f955b8ab70ffab11bb43091591b7822ca76c
downloadaur-485288e083a0369144477884904d588d6a903361.tar.gz
Initial update to AUR4.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--gregorio.install20
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3083444dc718
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gregorio
+ pkgdesc = Command-line tool to typeset Gregorian chant
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = http://gregorio-project.github.io
+ install = gregorio.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = texlive-core
+ depends = texlive-fontsextra
+ depends = texlive-bin
+ depends = texlive-formatsextra
+ depends = texlive-latexextra
+ provides = gregorio
+ conflicts = gregorio-svn
+ conflicts = gregorio-git
+ conflicts = gregoriotex
+ source = https://github.com/gregorio-project/gregorio/releases/download/v3.0.2/gregorio-3.0.2.tar.gz
+ sha256sums = da7e35e642f5bc40e55bf6e795513a225e6b7e80086a021e516c2daf69fc2e74
+
+pkgname = gregorio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdc271bd9f67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Br Anthony VanBerkum <anthonyvbop AT gmail DOT com>
+# Contributor: LaƩrcio de Sousa <lbsousajr AT gmail DOT com>
+# Contributor: David Gippner davidgippner at googlemail dot com
+pkgbase=gregorio
+pkgname=$pkgbase
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Command-line tool to typeset Gregorian chant"
+url=http://gregorio-project.github.io
+arch=("i686" "x86_64")
+license=("GPL")
+depends=("texlive-core" "texlive-fontsextra" "texlive-bin" "texlive-formatsextra" "texlive-latexextra")
+conflicts=("gregorio-svn" "gregorio-git" "gregoriotex")
+provides=("gregorio")
+install=gregorio.install
+source=("https://github.com/gregorio-project/gregorio/releases/download/v3.0.2/gregorio-3.0.2.tar.gz")
+sha256sums=("da7e35e642f5bc40e55bf6e795513a225e6b7e80086a021e516c2daf69fc2e74")
+
+
+prepare() {
+ # Standardise src dir name without using a private variable.
+ mv "$srcdir/$pkgbase-$pkgver/" "$srcdir/$pkgbase/"
+ msg "Configuring..."
+ cd "$srcdir/$pkgbase/"
+ autoreconf -f -i
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ msg "Compiling gregorio..."
+ cd "$srcdir/$pkgbase/"
+ make -j || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgbase/"
+ msg "Installing gregorio..."
+ make -j DESTDIR="$pkgdir/" install || return 1
+ msg "Installing fonts and TeX files..."
+ cd "$srcdir/$pkgbase/"
+ ./install-gtex.sh dir:$pkgdir/usr/share/texmf-dist || return 1
+}
diff --git a/gregorio.install b/gregorio.install
new file mode 100644
index 000000000000..eb41a05bcee3
--- /dev/null
+++ b/gregorio.install
@@ -0,0 +1,20 @@
+# Maintainer: Anthony VanBerkum <anthonyvbop AT gmail DOT com>
+# Contributor: David Gippner davidgippner at googlemail dot com
+
+post_install() {
+ _tex_update
+}
+
+post_upgrade() {
+ _tex_update
+ echo "Be sure to check https://github.com/gregorio-project/gregorio/releases for any changes required in your TeX files."
+}
+
+post_remove() {
+ _tex_update
+}
+
+_tex_update() {
+ echo "Updating TeX database..."
+ texhash
+}