summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2018-08-14 20:15:26 -0400
committerAndrew O'Neill2018-08-14 20:15:26 -0400
commit6c237fc27b5c31b4dfb34ce2f0f1d231955d444a (patch)
tree6f722d01e5204416b5ea4a7e4f91a0dbd3672153
parentbf8e46b773f8847b8f8177f10803e50bf09d36a8 (diff)
downloadaur-6c237fc27b5c31b4dfb34ce2f0f1d231955d444a.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b1f97f3dd18..7195f8124c34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = gretl
pkgdesc = A cross-platform software package for econometric analysis, written in the C programming language
- pkgver = 2018a
+ pkgver = 2018b
pkgrel = 1
url = http://gretl.sourceforge.net/
- arch = i686
arch = x86_64
license = GPL
depends = gtksourceview3
@@ -15,9 +14,10 @@ pkgbase = gretl
depends = gmp
optdepends = readline: provides a nice editable command line in gretlcli
optdepends = JSON-GLib: provides for parsing of data from various websites
+ optdepends = openmpi: provides means for dividing labor among multiple nodes
options = !makeflags
- source = https://downloads.sourceforge.net/project/gretl/gretl/2018a/gretl-2018a.tar.xz
- sha256sums = f961fe48613cffd263bcb7ee3dff0bf5189d75b45a5cd03a062cfca381b455b7
+ source = https://downloads.sourceforge.net/project/gretl/gretl/2018b/gretl-2018b.tar.xz
+ sha256sums = 5ee4f395a500895b7b5eee5eb9ff0709a4aef439dbd7c20f2477148ba9e3dee1
pkgname = gretl
diff --git a/PKGBUILD b/PKGBUILD
index 5e1445033f87..b9878bc6627c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
# Contributor: Thomas Mudrunka <harvie@@email..cz>
pkgname=gretl
-pkgver=2018a
+pkgver=2018b
pkgrel=1
pkgdesc='A cross-platform software package for econometric analysis, written in the C programming language'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://gretl.sourceforge.net/"
license=('GPL')
options=('!makeflags')
depends=('gtksourceview3' 'curl' 'lapack' 'mpfr' 'fftw' 'gnuplot' 'gmp')
-optdepends=('readline: provides a nice editable command line in gretlcli' 'JSON-GLib: provides for parsing of data from various websites')
-source=("https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz")
-sha256sums=('f961fe48613cffd263bcb7ee3dff0bf5189d75b45a5cd03a062cfca381b455b7')
+optdepends=('readline: provides a nice editable command line in gretlcli'
+ 'JSON-GLib: provides for parsing of data from various websites'
+ 'openmpi: provides means for dividing labor among multiple nodes')
+source=("https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('5ee4f395a500895b7b5eee5eb9ff0709a4aef439dbd7c20f2477148ba9e3dee1')
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
+
./configure --prefix=/usr --disable-xdg-utils
make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
}